Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Sato icon theme" |
| 2 | HOMEPAGE = "http://www.o-hand.com" |
| 3 | BUGTRACKER = "http://bugzilla.yoctoproject.org/" |
| 4 | |
| 5 | LICENSE = "CC-BY-SA-3.0" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=56a830bbe6e4697fe6cbbae01bb7c2b2" |
| 7 | SECTION = "x11" |
| 8 | |
| 9 | PR = "r6" |
| 10 | |
| 11 | DEPENDS = "icon-naming-utils-native libxml-simple-perl-native" |
| 12 | |
| 13 | SRC_URI = "http://pokylinux.org/releases/sato/${BPN}-${PV}.tar.gz \ |
| 14 | file://0001-Inherit-the-GNOME-icon-theme.patch" |
| 15 | |
| 16 | SRC_URI[md5sum] = "86a847f3128a43a9cf23b7029a656f50" |
| 17 | SRC_URI[sha256sum] = "0b0a2807a6a96918ac799a86094ec3e8e2c892be0fd679a4232c2a77f2f61732" |
| 18 | |
| 19 | inherit autotools pkgconfig allarch gtk-icon-cache perlnative |
| 20 | |
| 21 | # The configure script uses pkg-config to find native binaries to execute, so |
| 22 | # tell it to use our pkg-config-native wrapper. |
| 23 | export PKG_CONFIG = "pkg-config-native" |
| 24 | |
| 25 | FILES_${PN} += "${datadir}/icons/Sato" |
| 26 | |
| 27 | do_install_append() { |
| 28 | find ${D}${datadir}/icons/Sato/ -maxdepth 1 -type d -exec ln -s preferences-system.png {}/apps/preferences-desktop.png \; |
| 29 | find ${D}${datadir}/icons/Sato/ -maxdepth 1 -type d -exec ln -s file-manager.png {}/apps/system-file-manager.png \; |
| 30 | find ${D}${datadir}/icons/Sato/ -maxdepth 1 -type d -exec ln -s ../apps/terminal.png {}/places/computer.png \; |
| 31 | } |
| 32 | |
| 33 | # Explictly setting "Sato" as the default icon theme to avoid flickering from |
| 34 | # the desktop and settings daemon racing. This shouldn't be done here but in the sato image |
| 35 | pkg_postinst_${PN} () { |
| 36 | mkdir -p $D/etc/gtk-2.0 |
| 37 | |
| 38 | grep -s -q -e ^gtk-icon-theme-name.*\"Sato\" $D/etc/gtk-2.0/gtkrc || \ |
| 39 | echo 'gtk-icon-theme-name = "Sato"' >> $D/etc/gtk-2.0/gtkrc |
| 40 | } |