Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | # Copyright (C) 2017 Khem Raj <raj.khem@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | DESCRIPTION = "The LLVM Compiler Infrastructure" |
| 5 | HOMEPAGE = "http://llvm.org" |
Brad Bishop | f3f93bb | 2019-10-16 14:33:32 -0400 | [diff] [blame] | 6 | LICENSE = "Apache-2.0-with-LLVM-exception" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 7 | SECTION = "devel" |
| 8 | |
Brad Bishop | f3f93bb | 2019-10-16 14:33:32 -0400 | [diff] [blame] | 9 | LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=8a15a0759ef07f2682d2ba4b893c9afe" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 10 | |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 11 | DEPENDS = "libffi libxml2 zlib libedit ninja-native llvm-native" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 12 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 13 | COMPATIBLE_HOST_riscv64 = "null" |
| 14 | COMPATIBLE_HOST_riscv32 = "null" |
| 15 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 16 | RDEPENDS_${PN}_append_class-target = " ncurses-terminfo" |
| 17 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 18 | inherit cmake pkgconfig |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 19 | |
| 20 | PROVIDES += "llvm${PV}" |
| 21 | |
Andrew Geissler | 5f35090 | 2021-07-23 13:09:54 -0400 | [diff] [blame^] | 22 | PV = "12.0.0" |
Brad Bishop | f3f93bb | 2019-10-16 14:33:32 -0400 | [diff] [blame] | 23 | |
Andrew Geissler | 5f35090 | 2021-07-23 13:09:54 -0400 | [diff] [blame^] | 24 | MAJOR_VERSION = "${@oe.utils.trim_version("${PV}", 1)}" |
Brad Bishop | f3f93bb | 2019-10-16 14:33:32 -0400 | [diff] [blame] | 25 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 26 | LLVM_RELEASE = "${PV}" |
| 27 | LLVM_DIR = "llvm${LLVM_RELEASE}" |
| 28 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 29 | BRANCH = "release/${MAJOR_VERSION}.x" |
Andrew Geissler | c926e17 | 2021-05-07 16:11:35 -0500 | [diff] [blame] | 30 | SRCREV = "fa0971b87fb2c9d14d1bba2551e61f02f18f329b" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 31 | SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH} \ |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 32 | file://0006-llvm-TargetLibraryInfo-Undefine-libc-functions-if-th.patch;striplevel=2 \ |
| 33 | file://0007-llvm-allow-env-override-of-exe-path.patch;striplevel=2 \ |
Andrew Geissler | 09209ee | 2020-12-13 08:44:15 -0600 | [diff] [blame] | 34 | file://0001-AsmMatcherEmitter-sort-ClassInfo-lists-by-name-as-we.patch;striplevel=2 \ |
| 35 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 36 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 37 | UPSTREAM_CHECK_GITTAGREGEX = "llvmorg-(?P<pver>\d+(\.\d+)+)" |
| 38 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 39 | S = "${WORKDIR}/git/llvm" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 40 | |
| 41 | LLVM_INSTALL_DIR = "${WORKDIR}/llvm-install" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 42 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 43 | def get_llvm_arch(bb, d, arch_var): |
| 44 | import re |
| 45 | a = d.getVar(arch_var) |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 46 | if re.match(r'(i.86|athlon|x86.64)$', a): return 'X86' |
| 47 | elif re.match(r'arm$', a): return 'ARM' |
| 48 | elif re.match(r'armeb$', a): return 'ARM' |
| 49 | elif re.match(r'aarch64$', a): return 'AArch64' |
| 50 | elif re.match(r'aarch64_be$', a): return 'AArch64' |
| 51 | elif re.match(r'mips(isa|)(32|64|)(r6|)(el|)$', a): return 'Mips' |
Brad Bishop | f3f93bb | 2019-10-16 14:33:32 -0400 | [diff] [blame] | 52 | elif re.match(r'riscv(32|64)(eb|)$', a): return 'RISCV' |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 53 | elif re.match(r'p(pc|owerpc)(|64)', a): return 'PowerPC' |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 54 | else: |
| 55 | raise bb.parse.SkipRecipe("Cannot map '%s' to a supported LLVM architecture" % a) |
| 56 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 57 | def get_llvm_host_arch(bb, d): |
| 58 | return get_llvm_arch(bb, d, 'HOST_ARCH') |
| 59 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 60 | # |
| 61 | # Default to build all OE-Core supported target arches (user overridable). |
| 62 | # |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 63 | LLVM_TARGETS ?= "AMDGPU;${@get_llvm_host_arch(bb, d)}" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 64 | |
| 65 | ARM_INSTRUCTION_SET_armv5 = "arm" |
| 66 | ARM_INSTRUCTION_SET_armv4t = "arm" |
| 67 | |
| 68 | EXTRA_OECMAKE += "-DLLVM_ENABLE_ASSERTIONS=OFF \ |
| 69 | -DLLVM_ENABLE_EXPENSIVE_CHECKS=OFF \ |
| 70 | -DLLVM_ENABLE_PIC=ON \ |
| 71 | -DLLVM_BINDINGS_LIST='' \ |
| 72 | -DLLVM_LINK_LLVM_DYLIB=ON \ |
| 73 | -DLLVM_ENABLE_FFI=ON \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 74 | -DLLVM_ENABLE_RTTI=ON \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 75 | -DFFI_INCLUDE_DIR=$(pkg-config --variable=includedir libffi) \ |
| 76 | -DLLVM_OPTIMIZED_TABLEGEN=ON \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 77 | -DLLVM_TARGETS_TO_BUILD='${LLVM_TARGETS}' \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 78 | -DLLVM_TEMPORARILY_ALLOW_OLD_TOOLCHAIN=ON \ |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 79 | -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python3 \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 80 | -G Ninja" |
| 81 | |
| 82 | EXTRA_OECMAKE_append_class-target = "\ |
| 83 | -DCMAKE_CROSSCOMPILING:BOOL=ON \ |
| 84 | -DLLVM_TABLEGEN=${STAGING_BINDIR_NATIVE}/llvm-tblgen${PV} \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 85 | -DLLVM_CONFIG_PATH=${STAGING_BINDIR_NATIVE}/llvm-config${PV} \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 86 | " |
| 87 | |
| 88 | EXTRA_OECMAKE_append_class-nativesdk = "\ |
| 89 | -DCMAKE_CROSSCOMPILING:BOOL=ON \ |
| 90 | -DLLVM_TABLEGEN=${STAGING_BINDIR_NATIVE}/llvm-tblgen${PV} \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 91 | -DLLVM_CONFIG_PATH=${STAGING_BINDIR_NATIVE}/llvm-config${PV} \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 92 | " |
| 93 | |
| 94 | do_configure_prepend() { |
| 95 | # Fix paths in llvm-config |
| 96 | sed -i "s|sys::path::parent_path(CurrentPath))\.str()|sys::path::parent_path(sys::path::parent_path(CurrentPath))).str()|g" ${S}/tools/llvm-config/llvm-config.cpp |
| 97 | sed -ri "s#/(bin|include|lib)(/?\")#/\1/${LLVM_DIR}\2#g" ${S}/tools/llvm-config/llvm-config.cpp |
| 98 | sed -ri "s#lib/${LLVM_DIR}#${baselib}/${LLVM_DIR}#g" ${S}/tools/llvm-config/llvm-config.cpp |
| 99 | } |
| 100 | |
Andrew Geissler | 09209ee | 2020-12-13 08:44:15 -0600 | [diff] [blame] | 101 | # patch out build host paths for reproducibility |
| 102 | do_compile_prepend_class-target() { |
| 103 | sed -i -e "s,${WORKDIR},,g" ${B}/tools/llvm-config/BuildVariables.inc |
| 104 | } |
| 105 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 106 | do_compile() { |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 107 | ninja -v ${PARALLEL_MAKE} |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 108 | } |
| 109 | |
| 110 | do_compile_class-native() { |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 111 | ninja -v ${PARALLEL_MAKE} llvm-config llvm-tblgen |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 112 | } |
| 113 | |
| 114 | do_install() { |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 115 | DESTDIR=${LLVM_INSTALL_DIR} ninja -v install |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 116 | install -D -m 0755 ${B}/bin/llvm-config ${D}${libdir}/${LLVM_DIR}/llvm-config |
| 117 | |
| 118 | install -d ${D}${bindir}/${LLVM_DIR} |
| 119 | cp -r ${LLVM_INSTALL_DIR}${bindir}/* ${D}${bindir}/${LLVM_DIR}/ |
| 120 | |
| 121 | install -d ${D}${includedir}/${LLVM_DIR} |
| 122 | cp -r ${LLVM_INSTALL_DIR}${includedir}/* ${D}${includedir}/${LLVM_DIR}/ |
| 123 | |
| 124 | install -d ${D}${libdir}/${LLVM_DIR} |
| 125 | |
| 126 | # The LLVM sources have "/lib" embedded and so we cannot completely rely on the ${libdir} variable |
| 127 | if [ -d ${LLVM_INSTALL_DIR}${libdir}/ ]; then |
| 128 | cp -r ${LLVM_INSTALL_DIR}${libdir}/* ${D}${libdir}/${LLVM_DIR}/ |
| 129 | elif [ -d ${LLVM_INSTALL_DIR}${prefix}/lib ]; then |
| 130 | cp -r ${LLVM_INSTALL_DIR}${prefix}/lib/* ${D}${libdir}/${LLVM_DIR}/ |
| 131 | elif [ -d ${LLVM_INSTALL_DIR}${prefix}/lib64 ]; then |
| 132 | cp -r ${LLVM_INSTALL_DIR}${prefix}/lib64/* ${D}${libdir}/${LLVM_DIR}/ |
| 133 | fi |
| 134 | |
| 135 | # Remove unnecessary cmake files |
| 136 | rm -rf ${D}${libdir}/${LLVM_DIR}/cmake |
| 137 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 138 | ln -s ${LLVM_DIR}/libLLVM-${MAJOR_VERSION}${SOLIBSDEV} ${D}${libdir}/libLLVM-${MAJOR_VERSION}${SOLIBSDEV} |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 139 | |
| 140 | # We'll have to delete the libLLVM.so due to multiple reasons... |
| 141 | rm -rf ${D}${libdir}/${LLVM_DIR}/libLLVM.so |
| 142 | rm -rf ${D}${libdir}/${LLVM_DIR}/libLTO.so |
| 143 | } |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 144 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 145 | do_install_class-native() { |
| 146 | install -D -m 0755 ${B}/bin/llvm-tblgen ${D}${bindir}/llvm-tblgen${PV} |
| 147 | install -D -m 0755 ${B}/bin/llvm-config ${D}${bindir}/llvm-config${PV} |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 148 | install -D -m 0755 ${B}/lib/libLLVM-${MAJOR_VERSION}.so ${D}${libdir}/libLLVM-${MAJOR_VERSION}.so |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 149 | } |
| 150 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 151 | PACKAGES =+ "${PN}-bugpointpasses ${PN}-llvmhello ${PN}-libllvm ${PN}-liboptremarks ${PN}-liblto" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 152 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 153 | RRECOMMENDS_${PN}-dev += "${PN}-bugpointpasses ${PN}-llvmhello ${PN}-liboptremarks" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 154 | |
| 155 | FILES_${PN}-bugpointpasses = "\ |
| 156 | ${libdir}/${LLVM_DIR}/BugpointPasses.so \ |
| 157 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 158 | |
| 159 | FILES_${PN}-libllvm = "\ |
| 160 | ${libdir}/${LLVM_DIR}/libLLVM-${MAJOR_VERSION}.so \ |
| 161 | ${libdir}/libLLVM-${MAJOR_VERSION}.so \ |
| 162 | " |
| 163 | |
| 164 | FILES_${PN}-liblto += "\ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 165 | ${libdir}/${LLVM_DIR}/libLTO.so.* \ |
| 166 | " |
| 167 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 168 | FILES_${PN}-liboptremarks += "\ |
Brad Bishop | f3f93bb | 2019-10-16 14:33:32 -0400 | [diff] [blame] | 169 | ${libdir}/${LLVM_DIR}/libRemarks.so.* \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 170 | " |
| 171 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 172 | FILES_${PN}-llvmhello = "\ |
| 173 | ${libdir}/${LLVM_DIR}/LLVMHello.so \ |
| 174 | " |
| 175 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 176 | FILES_${PN}-dev += " \ |
| 177 | ${libdir}/${LLVM_DIR}/llvm-config \ |
Brad Bishop | f3f93bb | 2019-10-16 14:33:32 -0400 | [diff] [blame] | 178 | ${libdir}/${LLVM_DIR}/libRemarks.so \ |
Andrew Geissler | 5f35090 | 2021-07-23 13:09:54 -0400 | [diff] [blame^] | 179 | ${libdir}/${LLVM_DIR}/libLLVM-${PV}.so \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 180 | " |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 181 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 182 | FILES_${PN}-staticdev += "\ |
| 183 | ${libdir}/${LLVM_DIR}/*.a \ |
| 184 | " |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 185 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 186 | INSANE_SKIP_${PN}-libllvm += "dev-so" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 187 | |
| 188 | BBCLASSEXTEND = "native nativesdk" |