Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Web-based MySQL administration interface" |
| 2 | HOMEPAGE = "http://www.phpmyadmin.net" |
| 3 | # Main code is GPLv2, vendor/tecnickcom/tcpdf is under LGPLv3, js/jquery is under MIT |
| 4 | LICENSE = "GPLv2 & LGPLv3 & MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 6 | file://vendor/tecnickcom/tcpdf/LICENSE.TXT;md5=5c87b66a5358ebcc495b03e0afcd342c \ |
| 7 | file://js/jquery/MIT-LICENSE.txt;md5=e43aa437a6a1ba421653bd5034333bf9 \ |
| 8 | " |
| 9 | |
| 10 | SRC_URI = "https://files.phpmyadmin.net/phpMyAdmin/${PV}/phpMyAdmin-${PV}-all-languages.tar.xz \ |
| 11 | file://apache.conf \ |
| 12 | " |
| 13 | |
| 14 | SRC_URI[md5sum] = "0a862e3fa52c8b9078e0441ee82be831" |
| 15 | SRC_URI[sha256sum] = "f19b503f0afb0dd3389d4bb11dab3f438d36e85eef11a5c400c592fd5f539398" |
| 16 | |
| 17 | UPSTREAM_CHECK_URI = "https://www.phpmyadmin.net/downloads/" |
| 18 | UPSTREAM_CHECK_REGEX = "phpMyAdmin-(?P<pver>\d+(\.\d+)+)-all-languages.tar.xz" |
| 19 | |
| 20 | S = "${WORKDIR}/phpMyAdmin-${PV}-all-languages" |
| 21 | |
| 22 | inherit allarch |
| 23 | |
| 24 | do_install() { |
| 25 | install -d ${D}${datadir}/${BPN} |
| 26 | cp -R --no-dereference --preserve=mode,links -v * ${D}${datadir}/${BPN} |
| 27 | chown -R root:root ${D}${datadir}/${BPN} |
| 28 | # Don't install patches to target |
| 29 | rm -rf ${D}${datadir}/${BPN}/patches |
| 30 | |
| 31 | install -d ${D}${sysconfdir}/apache2/conf.d |
| 32 | install -m 0644 ${WORKDIR}/apache.conf ${D}${sysconfdir}/apache2/conf.d/phpmyadmin.conf |
| 33 | |
| 34 | # Remove a few scripts that explicitly require bash (!) |
| 35 | rm -f ${D}${datadir}/phpmyadmin/libraries/transformations/*.sh |
| 36 | } |
| 37 | |
| 38 | FILES_${PN} = "${datadir}/${BPN} \ |
| 39 | ${sysconfdir}/apache2/conf.d" |
| 40 | |
| 41 | RDEPENDS_${PN} += "bash" |