Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "Intel(R) Enclosure LED Utilities" |
| 2 | |
| 3 | DESCRIPTION = "The utilities are designed primarily to be used on storage servers \ |
| 4 | utilizing MD devices (aka Linux Software RAID) for RAID arrays.\ |
| 5 | " |
| 6 | HOMEPAGE = "https://github.com/intel/ledmon" |
| 7 | |
| 8 | LICENSE = "GPLv2" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \ |
| 10 | " |
| 11 | |
| 12 | DEPENDS = "sg3-utils udev" |
| 13 | |
| 14 | inherit systemd |
| 15 | |
| 16 | SYSTEMD_SERVICE_${PN} = "ledmon.service" |
| 17 | |
| 18 | SRC_URI = "git://github.com/intel/ledmon;branch=master \ |
| 19 | file://0002-include-sys-select.h-and-sys-types.h.patch \ |
| 20 | " |
| 21 | |
| 22 | SRCREV = "ad1304ca1363d727425a1f23703c523e21feae4f" |
| 23 | |
| 24 | COMPATIBLE_HOST = "(i.86|x86_64).*-linux" |
| 25 | COMPATIBLE_HOST_libc-musl = "null" |
| 26 | |
| 27 | S = "${WORKDIR}/git" |
| 28 | EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}' CFLAGS='${CFLAGS}'" |
| 29 | |
| 30 | do_install_append() { |
| 31 | install -d ${D}/${systemd_unitdir}/system |
| 32 | oe_runmake DESTDIR=${D} install |
| 33 | oe_runmake DESTDIR=${D}${systemd_unitdir}/system install-systemd |
| 34 | } |