Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 1 | SUMMARY = "WebKit based web browser for GNOME" |
| 2 | LICENSE = "GPLv2+" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 4 | |
| 5 | DEPENDS = "libsoup-2.4 webkitgtk gtk+3 iso-codes ca-certificates avahi libnotify gcr libwnck3 \ |
| 6 | gsettings-desktop-schemas gnome-desktop3 libxml2-native intltool-native" |
| 7 | |
| 8 | inherit gnomebase gsettings distro_features_check upstream-version-is-even |
| 9 | # libwnck3 is x11 only |
| 10 | REQUIRED_DISTRO_FEATURES = "x11" |
| 11 | |
| 12 | SRC_URI += "file://0001-yelp.m4-drop-the-check-for-itstool.patch" |
| 13 | SRC_URI[archive.md5sum] = "172b78256100e8d3c629764abd0e1495" |
| 14 | SRC_URI[archive.sha256sum] = "be699d484371111abae754e669187215df73e21533f461e513b79537d7a1c1c1" |
| 15 | |
| 16 | EXTRA_OECONF += " --disable-nss --with-distributor-name=${DISTRO}" |
| 17 | |
| 18 | do_configure_prepend() { |
| 19 | touch ${S}/gnome-doc-utils.make |
| 20 | sed -i -e s:help::g ${S}/Makefile.am |
| 21 | } |
| 22 | |
| 23 | FILES_${PN} += "${datadir}/appdata ${datadir}/dbus-1 ${datadir}/gnome-shell/search-providers" |
| 24 | RDEPENDS_${PN} = "iso-codes adwaita-icon-theme" |
| 25 | RRECOMMENDS_${PN} = "ca-certificates" |
| 26 | |