Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Ninja is a small build system with a focus on speed." |
| 2 | HOMEPAGE = "http://martine.github.com/ninja/" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=a81586a64ad4e476c791cda7e2f2c52e" |
| 5 | |
| 6 | DEPENDS = "re2c-native ninja-native" |
| 7 | |
| 8 | SRCREV = "b25c08bda4949192c69cea4cee057887341a2ffc" |
| 9 | |
| 10 | SRC_URI = "git://github.com/ninja-build/ninja.git;branch=release \ |
| 11 | file://fix-musl.patch \ |
| 12 | " |
| 13 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | do_configure[noexec] = "1" |
| 18 | |
| 19 | do_compile_class-native() { |
| 20 | ./configure.py --bootstrap |
| 21 | } |
| 22 | |
| 23 | do_compile() { |
| 24 | ./configure.py |
| 25 | ninja |
| 26 | } |
| 27 | |
| 28 | do_install() { |
| 29 | install -D -m 0755 ${S}/ninja ${D}${bindir}/ninja |
| 30 | } |
| 31 | |
| 32 | BBCLASSEXTEND = "native nativesdk" |