Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | require gstreamer1.0-plugins-common.inc |
| 2 | |
| 3 | LICENSE = "GPLv2+ & LGPLv2+" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d \ |
| 5 | file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607" |
| 6 | |
| 7 | SRC_URI = " \ |
| 8 | https://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-${PV}.tar.xz \ |
| 9 | file://get-caps-from-src-pad-when-query-caps.patch \ |
| 10 | file://0001-meson-build-gir-even-when-cross-compiling-if-introsp.patch \ |
| 11 | file://0002-meson-Add-variables-for-gir-files.patch \ |
| 12 | file://0003-ssaparse-enhance-SSA-text-lines-parsing.patch \ |
| 13 | file://0005-viv-fb-Make-sure-config.h-is-included.patch \ |
| 14 | file://0009-glimagesink-Downrank-to-marginal.patch \ |
| 15 | " |
| 16 | SRC_URI[md5sum] = "3fdb32823535799a748c1fc14f978e2c" |
| 17 | SRC_URI[sha256sum] = "b13e73e2fe74a4166552f9577c3dcb24bed077021b9c7fa600d910ec6987816a" |
| 18 | |
| 19 | S = "${WORKDIR}/gst-plugins-base-${PV}" |
| 20 | |
| 21 | DEPENDS += "iso-codes util-linux zlib" |
| 22 | |
| 23 | inherit gobject-introspection gtk-doc |
| 24 | |
| 25 | PACKAGES_DYNAMIC =+ "^libgst.*" |
| 26 | |
| 27 | # opengl packageconfig factored out to make it easy for distros |
| 28 | # and BSP layers to choose OpenGL APIs/platforms/window systems |
| 29 | PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl', '', d)}" |
| 30 | |
| 31 | PACKAGECONFIG ??= " \ |
| 32 | ${GSTREAMER_ORC} \ |
| 33 | ${PACKAGECONFIG_GL} \ |
| 34 | ${@bb.utils.filter('DISTRO_FEATURES', 'alsa x11', d)} \ |
| 35 | jpeg ogg pango png theora vorbis \ |
| 36 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland egl', '', d)} \ |
| 37 | " |
| 38 | |
| 39 | OPENGL_APIS = 'opengl gles2' |
| 40 | OPENGL_PLATFORMS = 'egl' |
| 41 | |
| 42 | X11DEPENDS = "virtual/libx11 libsm libxrender libxv" |
| 43 | X11ENABLEOPTS = "-Dx11=enabled -Dxvideo=enabled -Dxshm=enabled" |
| 44 | X11DISABLEOPTS = "-Dx11=disabled -Dxvideo=disabled -Dxshm=disabled" |
| 45 | |
| 46 | PACKAGECONFIG[alsa] = "-Dalsa=enabled,-Dalsa=disabled,alsa-lib" |
| 47 | PACKAGECONFIG[cdparanoia] = "-Dcdparanoia=enabled,-Dcdparanoia=disabled,cdparanoia" |
| 48 | PACKAGECONFIG[jpeg] = "-Dgl-jpeg=enabled,-Dgl-jpeg=disabled,jpeg" |
| 49 | PACKAGECONFIG[ogg] = "-Dogg=enabled,-Dogg=disabled,libogg" |
| 50 | PACKAGECONFIG[opus] = "-Dopus=enabled,-Dopus=disabled,libopus" |
| 51 | PACKAGECONFIG[pango] = "-Dpango=enabled,-Dpango=disabled,pango" |
| 52 | PACKAGECONFIG[png] = "-Dgl-png=enabled,-Dgl-png=disabled,libpng" |
| 53 | PACKAGECONFIG[theora] = "-Dtheora=enabled,-Dtheora=disabled,libtheora" |
| 54 | PACKAGECONFIG[tremor] = "-Dtremor=enabled,-Dtremor=disabled,tremor" |
| 55 | PACKAGECONFIG[visual] = "-Dlibvisual=enabled,-Dlibvisual=disabled,libvisual" |
| 56 | PACKAGECONFIG[vorbis] = "-Dvorbis=enabled,-Dvorbis=disabled,libvorbis" |
| 57 | PACKAGECONFIG[x11] = "${X11ENABLEOPTS},${X11DISABLEOPTS},${X11DEPENDS}" |
| 58 | |
| 59 | # OpenGL API packageconfigs |
| 60 | PACKAGECONFIG[opengl] = ",,virtual/libgl libglu" |
| 61 | PACKAGECONFIG[gles2] = ",,virtual/libgles2" |
| 62 | |
| 63 | # OpenGL platform packageconfigs |
| 64 | PACKAGECONFIG[egl] = ",,virtual/egl" |
| 65 | |
| 66 | # OpenGL window systems (except for X11) |
| 67 | PACKAGECONFIG[gbm] = ",,virtual/libgbm libgudev libdrm" |
| 68 | PACKAGECONFIG[wayland] = ",,wayland-native wayland wayland-protocols libdrm" |
| 69 | PACKAGECONFIG[dispmanx] = ",,virtual/libomxil" |
| 70 | |
| 71 | OPENGL_WINSYS_append = "${@bb.utils.contains('PACKAGECONFIG', 'x11', ' x11', '', d)}" |
| 72 | OPENGL_WINSYS_append = "${@bb.utils.contains('PACKAGECONFIG', 'gbm', ' gbm', '', d)}" |
| 73 | OPENGL_WINSYS_append = "${@bb.utils.contains('PACKAGECONFIG', 'wayland', ' wayland', '', d)}" |
| 74 | OPENGL_WINSYS_append = "${@bb.utils.contains('PACKAGECONFIG', 'dispmanx', ' dispmanx', '', d)}" |
| 75 | |
| 76 | EXTRA_OEMESON += " \ |
| 77 | -Dgl-graphene=disabled \ |
| 78 | ${@get_opengl_cmdline_list('gl_api', d.getVar('OPENGL_APIS'), d)} \ |
| 79 | ${@get_opengl_cmdline_list('gl_platform', d.getVar('OPENGL_PLATFORMS'), d)} \ |
| 80 | ${@get_opengl_cmdline_list('gl_winsys', d.getVar('OPENGL_WINSYS'), d)} \ |
| 81 | " |
| 82 | |
| 83 | GTKDOC_MESON_OPTION = "gtk_doc" |
| 84 | GTKDOC_MESON_ENABLE_FLAG = "enabled" |
| 85 | GTKDOC_MESON_DISABLE_FLAG = "disabled" |
| 86 | |
| 87 | FILES_${PN}-dev += "${libdir}/gstreamer-1.0/include/gst/gl/gstglconfig.h" |
| 88 | FILES_${MLPREFIX}libgsttag-1.0 += "${datadir}/gst-plugins-base/1.0/license-translations.dict" |
| 89 | |
| 90 | def get_opengl_cmdline_list(switch_name, options, d): |
| 91 | selected_options = [] |
| 92 | if bb.utils.contains('DISTRO_FEATURES', 'opengl', True, False, d): |
| 93 | for option in options.split(): |
| 94 | if bb.utils.contains('PACKAGECONFIG', option, True, False, d): |
| 95 | selected_options += [option] |
| 96 | if selected_options: |
| 97 | return '-D' + switch_name + '=' + ','.join(selected_options) |
| 98 | else: |
| 99 | return '' |