Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Linux man-pages" |
| 2 | DESCRIPTION = "The Linux man-pages project documents the Linux kernel and C library interfaces that are employed by user programs" |
| 3 | SECTION = "console/utils" |
| 4 | HOMEPAGE = "http://www.kernel.org/pub/linux/docs/man-pages" |
| 5 | LICENSE = "GPL-2.0-or-later & GPL-2.0-only & GPL-1.0-or-later & BSD-2-Clause & BSD-3-Clause & BSD-4-Clause & MIT" |
| 6 | |
| 7 | LIC_FILES_CHKSUM = "file://README;md5=26901408d8cfd6f6675f8b49daf9cc74 \ |
| 8 | file://LICENSES/BSD-2-Clause.txt;md5=d0f280d1058e77e66264a9b9e10e6c89 \ |
| 9 | file://LICENSES/BSD-3-Clause.txt;md5=71f739ef75581cae312e8c711bcdab16 \ |
| 10 | file://LICENSES/BSD-4-Clause-UC.txt;md5=1da3cf8ad50cd8d5d1de3cfc53196d01 \ |
| 11 | file://LICENSES/GPL-1.0-or-later.txt;md5=e5b7c80002ef72ab868b43ce47b65125 \ |
| 12 | file://LICENSES/GPL-2.0-only.txt;md5=3d26203303a722dedc6bf909d95ba815 \ |
| 13 | file://LICENSES/GPL-2.0-or-later.txt;md5=3d26203303a722dedc6bf909d95ba815 \ |
| 14 | file://LICENSES/Linux-man-pages-copyleft.txt;md5=173b960c686ff2d26f043ddaeb63f6ce \ |
| 15 | file://LICENSES/MIT.txt;md5=7dda4e90ded66ab88b86f76169f28663 \ |
| 16 | " |
| 17 | SRC_URI = "${KERNELORG_MIRROR}/linux/docs/${BPN}/${BP}.tar.gz" |
| 18 | |
| 19 | SRC_URI[sha256sum] = "968def9e7055c9cbca9a4f21f79677b02ac8b0d2fa62ceea7bd8ef4dcc6cac41" |
| 20 | |
| 21 | inherit manpages |
| 22 | |
| 23 | MAN_PKG = "${PN}" |
| 24 | |
| 25 | PACKAGECONFIG ??= "" |
| 26 | PACKAGECONFIG[manpages] = "" |
| 27 | |
| 28 | do_configure[noexec] = "1" |
| 29 | do_compile[noexec] = "1" |
| 30 | |
| 31 | do_install() { |
| 32 | oe_runmake install prefix=${prefix} DESTDIR=${D} |
| 33 | } |
| 34 | |
| 35 | # Only deliveres man-pages so FILES:${PN} gets everything |
| 36 | FILES:${PN}-doc = "" |
| 37 | FILES:${PN} = "${mandir}/*" |
| 38 | |
| 39 | inherit update-alternatives |
| 40 | |
| 41 | ALTERNATIVE_PRIORITY = "100" |
| 42 | ALTERNATIVE:${PN} = "crypt.3 crypt_r.3 getspnam.3 passwd.5" |
| 43 | ALTERNATIVE_LINK_NAME[crypt.3] = "${mandir}/man3/crypt.3" |
| 44 | ALTERNATIVE_LINK_NAME[crypt_r.3] = "${mandir}/man3/crypt_r.3" |
| 45 | ALTERNATIVE_LINK_NAME[getspnam.3] = "${mandir}/man3/getspnam.3" |
| 46 | ALTERNATIVE_LINK_NAME[passwd.5] = "${mandir}/man5/passwd.5" |