Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "Generic font configuration library" |
| 2 | DESCRIPTION = "Fontconfig is a font configuration and customization library, which \ |
| 3 | does not depend on the X Window System. It is designed to locate \ |
| 4 | fonts within the system and select them according to requirements \ |
| 5 | specified by applications. \ |
| 6 | Fontconfig is not a rasterization library, nor does it impose a \ |
| 7 | particular rasterization library on the application. The X-specific \ |
| 8 | library 'Xft' uses fontconfig along with freetype to specify and \ |
| 9 | rasterize fonts." |
| 10 | |
| 11 | HOMEPAGE = "http://www.fontconfig.org" |
| 12 | BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=fontconfig" |
| 13 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 14 | LICENSE = "MIT & MIT & PD" |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 15 | LIC_FILES_CHKSUM = "file://COPYING;md5=00252fd272bf2e722925613ad74cb6c7 \ |
| 16 | file://src/fcfreetype.c;endline=45;md5=ce976b310a013a6ace6b60afa71851c1 \ |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 17 | " |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 18 | |
| 19 | SECTION = "libs" |
| 20 | |
| 21 | DEPENDS = "expat freetype zlib gperf-native util-linux" |
| 22 | |
| 23 | SRC_URI = "http://fontconfig.org/release/fontconfig-${PV}.tar.gz \ |
| 24 | file://revert-static-pkgconfig.patch \ |
| 25 | " |
| 26 | |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 27 | SRC_URI[sha256sum] = "3ba2dd92158718acec5caaf1a716043b5aa055c27b081d914af3ccb40dce8a55" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 28 | |
| 29 | UPSTREAM_CHECK_REGEX = "fontconfig-(?P<pver>\d+\.\d+\.(?!9\d+)\d+)" |
| 30 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 31 | do_configure:prepend() { |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 32 | # work around https://bugs.freedesktop.org/show_bug.cgi?id=101280 |
| 33 | rm -f ${S}/src/fcobjshash.h ${S}/src/fcobjshash.gperf |
| 34 | } |
| 35 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 36 | do_install:append:class-target() { |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 37 | # duplicate fc-cache for postinstall script |
| 38 | mkdir -p ${D}${libexecdir} |
| 39 | ln ${D}${bindir}/fc-cache ${D}${libexecdir}/${MLPREFIX}fc-cache |
| 40 | } |
| 41 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 42 | do_install:append:class-nativesdk() { |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 43 | # duplicate fc-cache for postinstall script |
| 44 | mkdir -p ${D}${libexecdir} |
| 45 | ln ${D}${bindir}/fc-cache ${D}${libexecdir}/${MLPREFIX}fc-cache |
| 46 | } |
| 47 | |
| 48 | PACKAGES =+ "fontconfig-utils" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 49 | FILES:${PN} =+ "${datadir}/xml/*" |
| 50 | FILES:${PN}-dev += "${datadir}/gettext/*" |
| 51 | FILES:fontconfig-utils = "${bindir}/* ${libexecdir}/*" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 52 | |
| 53 | # Work around past breakage in debian.bbclass |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 54 | RPROVIDES:fontconfig-utils = "libfontconfig-utils" |
| 55 | RREPLACES:fontconfig-utils = "libfontconfig-utils" |
| 56 | RCONFLICTS:fontconfig-utils = "libfontconfig-utils" |
| 57 | DEBIAN_NOAUTONAME:fontconfig-utils = "1" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 58 | |
| 59 | inherit autotools pkgconfig relative_symlinks gettext |
| 60 | |
| 61 | FONTCONFIG_CACHE_DIR ?= "${localstatedir}/cache/fontconfig" |
| 62 | |
| 63 | # comma separated list of additional directories |
| 64 | # /usr/share/fonts is already included by default (you can change it with --with-default-fonts) |
| 65 | FONTCONFIG_FONT_DIRS ?= "no" |
| 66 | |
| 67 | EXTRA_OECONF = " --disable-docs --with-default-fonts=${datadir}/fonts --with-cache-dir=${FONTCONFIG_CACHE_DIR} --with-add-fonts=${FONTCONFIG_FONT_DIRS}" |
| 68 | |
| 69 | BBCLASSEXTEND = "native nativesdk" |