Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "Open client for Cisco AnyConnect VPN" |
| 2 | LICENSE = "LGPL-2.1-only" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING.LGPL;md5=8c2e1ec1540fb3e0beb68361344cba7e" |
| 4 | |
| 5 | SRC_URI = " \ |
| 6 | git://git.infradead.org/users/dwmw2/openconnect.git;branch=master \ |
| 7 | " |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame^] | 8 | SRCREV = "5695cd6b0c7d42ca293ce0f00abcbe3d1ec4e609" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 9 | |
| 10 | DEPENDS = "vpnc libxml2 krb5 gettext-native" |
| 11 | RDEPENDS:${PN} = "bash python3-core vpnc-script" |
| 12 | |
| 13 | PACKAGECONFIG ??= "gnutls lz4 libproxy" |
| 14 | |
| 15 | # config defaults |
| 16 | PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls," |
| 17 | PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4," |
| 18 | PACKAGECONFIG[libproxy] = "--with-libproxy,--without-libproxy,libproxy," |
| 19 | |
| 20 | # not config defaults |
| 21 | PACKAGECONFIG[pcsc-lite] = "--with-libpcsclite,--without-libpcsclite,pcsc-lite," |
| 22 | |
| 23 | S = "${WORKDIR}/git" |
| 24 | |
| 25 | inherit autotools pkgconfig bash-completion |
| 26 | |
| 27 | EXTRA_OECONF += "--with-vpnc-script=${sysconfdir}/vpnc/vpnc-script \ |
| 28 | --disable-static" |
| 29 | |
| 30 | do_install:append() { |
| 31 | rm ${D}/usr/libexec/openconnect/hipreport-android.sh |
| 32 | } |