Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame^] | 1 | SUMMARY = "Memory Efficient Serialization Library" |
| 2 | HOMEPAGE = "https://github.com/google/flatbuffers" |
| 3 | SECTION = "console/tools" |
| 4 | LICENSE = "Apache-2.0" |
| 5 | |
| 6 | PACKAGE_BEFORE_PN = "${PN}-compiler" |
| 7 | |
| 8 | DEPENDS = "flatbuffers-native" |
| 9 | |
| 10 | RDEPENDS:${PN}-compiler = "${PN}" |
| 11 | RDEPENDS:${PN}-dev += "${PN}-compiler" |
| 12 | |
| 13 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 14 | |
| 15 | SRCREV = "615616cb5549a34bdf288c04bc1b94bd7a65c396" |
| 16 | SRC_URI = "git://github.com/google/flatbuffers.git;branch=master;protocol=https" |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | CVE_CHECK_IGNORE += "CVE-2020-35864" |
| 20 | |
| 21 | EXTRA_OECMAKE += " \ |
| 22 | -DFLATBUFFERS_BUILD_TESTS=OFF \ |
| 23 | -DFLATBUFFERS_BUILD_SHAREDLIB=ON \ |
| 24 | " |
| 25 | EXTRA_OECMAKE:append:class-target = " -DFLATBUFFERS_FLATC_EXECUTABLE=${STAGING_BINDIR_NATIVE}/flatc" |
| 26 | |
| 27 | inherit cmake python3native |
| 28 | |
| 29 | FILES:${PN}-compiler = "${bindir}" |
| 30 | |
| 31 | BBCLASSEXTEND = "native nativesdk" |