Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "Python 2 and 3 compatibility library" |
| 2 | HOMEPAGE = "https://xlsxwriter.readthedocs.io" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2b9a26d1a52d2c66df334bbdad23896a" |
| 6 | |
| 7 | inherit pypi setuptools3 |
| 8 | |
| 9 | PYPI_PACKAGE = "XlsxWriter" |
| 10 | |
| 11 | RDEPENDS:${PN} += " \ |
| 12 | python3-crypt \ |
| 13 | python3-datetime \ |
| 14 | python3-compression \ |
| 15 | python3-numbers \ |
| 16 | python3-io \ |
| 17 | " |
| 18 | |
| 19 | SRC_URI[sha256sum] = "e89f4a1d2fa2c9ea15cde77de95cd3fd8b0345d0efb3964623f395c8c4988b7f" |
| 20 | |
| 21 | BBCLASSEXTEND = "native nativesdk" |