Adriana Kobylak | 6161f45 | 2015-10-19 14:15:04 -0400 | [diff] [blame^] | 1 | SUMMARY = "Temp placeholder for skeleton function" |
| 2 | DESCRIPTION = "Temp placeholder for skeleton repository" |
| 3 | HOMEPAGE = "http://github.com/openbmc/skeleton" |
| 4 | PR = "r1" |
| 5 | |
| 6 | inherit obmc-phosphor-license |
| 7 | inherit obmc-phosphor-systemd |
| 8 | |
| 9 | DEPENDS += "glib-2.0" |
| 10 | RDEPENDS_${PN} += "python-subprocess" |
| 11 | SRC_URI += "git://github.com/openbmc/skeleton" |
| 12 | |
| 13 | SRCREV = "18d4591170779ceb81158c650d31c6c59115b2f2" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | do_compile() { |
| 18 | oe_runmake all |
| 19 | } |
| 20 | |
| 21 | do_install() { |
| 22 | install -d ${D}/${sbindir} ${D}${libdir} |
| 23 | for i in ${S}/bin/*.py ${S}/bin/*.exe ${S}/bin/tftpy/*.py; do |
| 24 | install $i ${D}/${sbindir} |
| 25 | done |
| 26 | install ${S}/bin/libopenbmc_intf.so ${D}/${libdir} |
| 27 | } |