Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Telepathy IM framework - Python package" |
| 2 | HOMEPAGE = "http://telepathy.freedesktop.org/wiki/" |
| 3 | LICENSE = "LGPLv2.1+" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1 \ |
| 5 | file://src/utils.py;beginline=1;endline=17;md5=9a07d1a9791a7429a14e7b25c6c86822" |
| 6 | |
| 7 | DEPENDS = "libxslt-native" |
| 8 | RDEPENDS_${PN} += "python-dbus" |
| 9 | |
| 10 | SRC_URI = "http://telepathy.freedesktop.org/releases/${BPN}/${BPN}-${PV}.tar.gz \ |
| 11 | file://parallel_make.patch \ |
| 12 | file://remove_duplicate_install.patch \ |
| 13 | file://telepathy-python_fix_for_automake_1.12.patch" |
| 14 | |
| 15 | PR = "r6" |
| 16 | |
| 17 | inherit autotools pythonnative |
| 18 | |
| 19 | SRC_URI[md5sum] = "f7ca25ab3c88874015b7e9728f7f3017" |
| 20 | SRC_URI[sha256sum] = "244c0e1bf4bbd78ae298ea659fe10bf3a73738db550156767cc2477aedf72376" |
| 21 | |
| 22 | FILES_${PN} += "\ |
| 23 | ${libdir}/python*/site-packages/telepathy/*.py \ |
| 24 | ${libdir}/python*/site-packages/telepathy/*/*.py \ |
| 25 | " |
| 26 | |
| 27 | do_install_append () { |
| 28 | rm -f ${D}${libdir}/python*/site-packages/telepathy/*.pyc |
| 29 | rm -f ${D}${libdir}/python*/site-packages/telepathy/*.pyo |
| 30 | rm -f ${D}${libdir}/python*/site-packages/telepathy/*/*.pyc |
| 31 | rm -f ${D}${libdir}/python*/site-packages/telepathy/*/*.pyo |
| 32 | } |