Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 1 | SUMMARY = "Persistent Memory Development Kit" |
| 2 | DESCRIPTION = "Persistent Memory Development Kit" |
| 3 | HOMEPAGE = "http://pmem.io" |
| 4 | SECTION = "libs" |
| 5 | LICENSE = "BSD" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=7db1106255a1baa80391fd2e21eebab7" |
| 7 | DEPENDS = "ndctl" |
| 8 | |
| 9 | # Required to have the fts.h header for musl |
| 10 | DEPENDS_append_libc-musl = " fts" |
| 11 | |
| 12 | S = "${WORKDIR}/git" |
| 13 | |
| 14 | SRC_URI = "git://github.com/pmem/pmdk.git \ |
| 15 | file://0001-jemalloc-jemalloc.cfg-Specify-the-host-when-building.patch \ |
| 16 | file://0002-Makefile-Don-t-install-the-docs.patch \ |
Brad Bishop | 63ae878 | 2019-10-09 09:56:13 -0400 | [diff] [blame^] | 17 | file://0001-os_posix-Use-__FreeBSD__-to-control-secure_getenv-de.patch \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 18 | " |
| 19 | |
Brad Bishop | 63ae878 | 2019-10-09 09:56:13 -0400 | [diff] [blame^] | 20 | SRCREV = "bc5e309485df61c452d08367e4b13ba9dfed5071" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 21 | |
| 22 | inherit autotools-brokensep pkgconfig |
| 23 | |
| 24 | # Fix jemalloc error: |
| 25 | # | configure: error: cannot run C compiled programs. |
| 26 | # | If you meant to cross compile, use `--host'. |
| 27 | # |
| 28 | # Also fix #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Werror=cpp] |
Brad Bishop | 63ae878 | 2019-10-09 09:56:13 -0400 | [diff] [blame^] | 29 | EXTRA_OEMAKE = "BUILD_EXAMPLES='n' HOST_SYS='${HOST_SYS}' EXTRA_CFLAGS='${SELECTED_OPTIMIZATION}' LIB_PREFIX=${baselib}" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 30 | |
| 31 | # Fix the missing fts libs when using musl |
| 32 | EXTRA_OEMAKE_append_libc-musl = " EXTRA_LIBS='-lfts'" |
| 33 | |
| 34 | do_install() { |
| 35 | oe_runmake prefix=${prefix} DESTDIR=${D} install |
| 36 | |
| 37 | # Remove uneeded files |
| 38 | rm -rf ${D}/usr/${baselib}/pmdk_debug |
| 39 | } |
| 40 | |
| 41 | # Include these by default otherwise the SDK is not very useful |
| 42 | FILES_${PN} += "${bindir}/pmempool ${bindir}/daxio" |
| 43 | FILES_${PN} += "${libdir}/*so*" |
| 44 | FILES_${PN} += "${libdir}/pkgconfig/*.pc" |
| 45 | FILES_${PN} += "${includedir}/libpmemobj++/* ${includedir}/libpmemobj/* /usr/*/include/" |
| 46 | FILES_${PN} += "/usr/etc" |
| 47 | FILES_${PN} += "/usr/share" |
| 48 | |
| 49 | COMPATIBLE_HOST='(x86_64).*' |