Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Connman config to setup wired interface on qemu machines" |
| 2 | DESCRIPTION = "This is the ConnMan configuration to set up a Wired \ |
| 3 | network interface for a qemu machine." |
| 4 | LICENSE = "GPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6" |
| 6 | |
| 7 | SRC_URI_append_qemuall = " file://wired.config \ |
| 8 | file://wired-setup \ |
| 9 | " |
| 10 | PR = "r2" |
| 11 | |
| 12 | S = "${WORKDIR}" |
| 13 | |
| 14 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 15 | |
Patrick Williams | f1e5d69 | 2016-03-30 15:21:19 -0500 | [diff] [blame] | 16 | FILES_${PN} = "${localstatedir}/* ${datadir}/*" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 17 | |
| 18 | do_install() { |
| 19 | #Configure Wired network interface in case of qemu* machines |
| 20 | if test -e ${WORKDIR}/wired.config && test -e ${WORKDIR}/wired-setup; then |
| 21 | install -d ${D}${localstatedir}/lib/connman |
| 22 | install -m 0644 ${WORKDIR}/wired.config ${D}${localstatedir}/lib/connman |
Patrick Williams | f1e5d69 | 2016-03-30 15:21:19 -0500 | [diff] [blame] | 23 | install -d ${D}${datadir}/connman |
| 24 | install -m 0755 ${WORKDIR}/wired-setup ${D}${datadir}/connman |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 25 | fi |
| 26 | } |