Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | require ruby.inc |
| 2 | |
| 3 | SRC_URI[md5sum] = "326e99ddc75381c7b50c85f7089f3260" |
| 4 | SRC_URI[sha256sum] = "5ffc0f317e429e6b29d4a98ac521c3ce65481bfd22a8cf845fa02a7b113d9b44" |
| 5 | |
| 6 | # it's unknown to configure script, but then passed to extconf.rb |
| 7 | # maybe it's not really needed as we're hardcoding the result with |
| 8 | # 0001-socket-extconf-hardcode-wide-getaddr-info-test-outco.patch |
| 9 | UNKNOWN_CONFIGURE_WHITELIST += "--enable-wide-getaddrinfo" |
| 10 | |
| 11 | PACKAGECONFIG ??= "" |
| 12 | PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)}" |
| 13 | |
| 14 | PACKAGECONFIG[valgrind] = "--with-valgrind=yes, --with-valgrind=no, valgrind" |
| 15 | PACKAGECONFIG[gpm] = "--with-gmp=yes, --with-gmp=no, gmp" |
| 16 | PACKAGECONFIG[ipv6] = ",--enable-wide-getaddrinfo," |
| 17 | |
| 18 | EXTRA_OECONF = "\ |
| 19 | --disable-versioned-paths \ |
| 20 | --disable-rpath \ |
| 21 | --disable-dtrace \ |
| 22 | --enable-shared \ |
| 23 | --enable-load-relative \ |
| 24 | " |
| 25 | |
| 26 | EXTRA_OEMAKE = " \ |
| 27 | LIBRUBYARG='-lruby-static' \ |
| 28 | " |
| 29 | |
| 30 | do_install() { |
| 31 | oe_runmake 'DESTDIR=${D}' install |
| 32 | } |
| 33 | |
| 34 | FILES_${PN} += "${datadir}/rubygems \ |
| 35 | ${datadir}/ri" |
| 36 | |
| 37 | FILES_${PN}-dbg += "${libdir}/ruby/*/.debug \ |
| 38 | ${libdir}/ruby/*/*/.debug \ |
| 39 | ${libdir}/ruby/*/*/*/.debug \ |
| 40 | ${libdir}/ruby/*/*/*/*/.debug" |
| 41 | |
| 42 | BBCLASSEXTEND = "native" |