Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Tools for monitoring & limiting user disk usage per filesystem" |
| 2 | SECTION = "base" |
| 3 | HOMEPAGE = "http://sourceforge.net/projects/linuxquota/" |
| 4 | BUGTRACKER = "http://sourceforge.net/tracker/?group_id=18136&atid=118136" |
| 5 | LICENSE = "BSD & GPLv2+ & LGPLv2.1+" |
| 6 | LIC_FILES_CHKSUM = "file://quota.c;beginline=1;endline=33;md5=331c7d77744bfe0ad24027f0651028ec \ |
| 7 | file://rquota_server.c;beginline=1;endline=20;md5=fe7e0d7e11c6f820f8fa62a5af71230f \ |
| 8 | file://svc_socket.c;beginline=1;endline=17;md5=24d5a8792da45910786eeac750be8ceb" |
| 9 | |
| 10 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/linuxquota/quota-tools/${PV}/quota-${PV}.tar.gz \ |
| 11 | file://config-tcpwrappers.patch \ |
| 12 | file://fcntl.patch \ |
| 13 | file://remove_non_posix_types.patch \ |
| 14 | " |
| 15 | SRC_URI_append_libc-musl = " file://replace_getrpcbynumber_r.patch" |
| 16 | |
| 17 | SRC_URI[md5sum] = "a8a5df262261e659716ccad2a5d6df0d" |
| 18 | SRC_URI[sha256sum] = "f4c2f48abf94bbdc396df33d276f2e9d19af58c232cb85eef9c174a747c33795" |
| 19 | |
| 20 | S = "${WORKDIR}/quota-tools" |
| 21 | |
| 22 | DEPENDS = "gettext-native e2fsprogs" |
| 23 | |
| 24 | inherit autotools-brokensep gettext pkgconfig |
| 25 | |
Patrick Williams | f1e5d69 | 2016-03-30 15:21:19 -0500 | [diff] [blame] | 26 | CFLAGS += "-I${STAGING_INCDIR}/tirpc" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 27 | LDFLAGS += "-ltirpc" |
| 28 | ASNEEDED = "" |
| 29 | EXTRA_OEMAKE += 'STRIP=""' |
| 30 | |
| 31 | PACKAGECONFIG ??= "tcp-wrappers rpc bsd" |
| 32 | PACKAGECONFIG_libc-musl = "tcp-wrappers rpc" |
| 33 | |
| 34 | PACKAGECONFIG[tcp-wrappers] = "--with-tcpwrappers,--without-tcpwrappers,tcp-wrappers" |
| 35 | PACKAGECONFIG[rpc] = "--enable-rpc=yes,--enable-rpc=no,libtirpc" |
| 36 | PACKAGECONFIG[bsd] = "--enable-bsd_behaviour=yes,--enable-bsd_behaviour=no," |
| 37 | |
| 38 | do_install() { |
| 39 | oe_runmake ROOTDIR=${D} install |
| 40 | } |