Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Pixman: Pixel Manipulation library" |
| 2 | |
| 3 | DESCRIPTION = "Pixman provides a library for manipulating pixel regions \ |
| 4 | -- a set of Y-X banded rectangles, image compositing using the \ |
| 5 | Porter/Duff model and implicit mask generation for geometric primitives \ |
| 6 | including trapezoids, triangles, and rectangles." |
| 7 | |
| 8 | require xorg-lib-common.inc |
| 9 | |
| 10 | LICENSE = "MIT & MIT-style & PD" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=14096c769ae0cbb5fcb94ec468be11b3 \ |
| 12 | file://pixman/pixman-matrix.c;endline=25;md5=ba6e8769bfaaee2c41698755af04c4be \ |
| 13 | file://pixman/pixman-arm-neon-asm.h;endline=24;md5=9a9cc1e51abbf1da58f4d9528ec9d49b \ |
| 14 | " |
| 15 | DEPENDS += "zlib libpng" |
| 16 | BBCLASSEXTEND = "native nativesdk" |
| 17 | |
| 18 | PE = "1" |
| 19 | |
| 20 | IWMMXT = "--disable-arm-iwmmxt" |
| 21 | LOONGSON_MMI = "--disable-loongson-mmi" |
| 22 | NEON = " --disable-arm-neon " |
| 23 | NEON_class-nativesdk = " --disable-arm-neon " |
| 24 | NEON_armv7a = " " |
| 25 | NEON_armv7a-vfp-neon = " " |
| 26 | |
| 27 | EXTRA_OECONF = "--disable-gtk ${IWMMXT} ${LOONGSON_MMI} ${NEON}" |
| 28 | EXTRA_OECONF_class-native = "--disable-gtk" |
| 29 | |
| 30 | SRC_URI += "\ |
| 31 | file://0001-ARM-qemu-related-workarounds-in-cpu-features-detecti.patch \ |
| 32 | file://mips-export-revert.patch \ |
| 33 | file://asm_include.patch \ |
Patrick Williams | f1e5d69 | 2016-03-30 15:21:19 -0500 | [diff] [blame] | 34 | file://0001-v3-test-add-a-check-for-FE_DIVBYZERO.patch \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 35 | " |
| 36 | |
| 37 | SRC_URI[md5sum] = "8a9e8f14743a39cf303803f369c1f344" |
| 38 | SRC_URI[sha256sum] = "201fc0d7d6bc0017496f2bd27b3ca14224aea0df6b624c5ee2dc0307a4ff14a4" |
| 39 | |
| 40 | REQUIRED_DISTRO_FEATURES = "" |