Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | # NOTE: |
| 2 | # You should use perl-module-encode rather than this package |
| 3 | # unless you specifically need a version newer than what is |
| 4 | # provided by perl. |
| 5 | |
| 6 | SUMMARY = "Encode - character encodings" |
| 7 | DESCRIPTION = "The \"Encode\" module provides the interfaces between \ |
| 8 | Perl's strings and the rest of the system. Perl strings are sequences \ |
| 9 | of characters." |
| 10 | |
| 11 | AUTHOR = "Dan Kogai <dankogai+cpan@gmail.com>" |
| 12 | HOMEPAGE = "https://metacpan.org/release/Encode" |
| 13 | SECTION = "lib" |
| 14 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 15 | LIC_FILES_CHKSUM = "file://META.json;beginline=8;endline=10;md5=b12e3be1e17a7e99ca4f429ff32c28b5" |
| 16 | |
| 17 | SRC_URI = "${CPAN_MIRROR}/authors/id/D/DA/DANKOGAI/Encode-${PV}.tar.gz" |
Andrew Geissler | 72956ed | 2021-01-08 16:11:14 -0600 | [diff] [blame] | 18 | SRC_URI[md5sum] = "3889cf6d1b75e486d54f9fd6517a02b4" |
| 19 | SRC_URI[sha256sum] = "ed063d01d01a140a3a3ec0aeba2f2b4849a35c18ca96ac231a5d7c7d54d17b5b" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 20 | |
| 21 | UPSTREAM_CHECK_REGEX = "Encode\-(?P<pver>(\d+\.\d+))(?!_\d+).tar" |
| 22 | |
| 23 | S = "${WORKDIR}/Encode-${PV}" |
| 24 | |
| 25 | inherit cpan ptest-perl |
| 26 | |
| 27 | do_install_prepend() { |
| 28 | # Requires "-T" (taint) option on command line |
| 29 | rm -rf ${B}/t/taint.t |
| 30 | # Circular dependency of perl-module-open on perl-module-encode |
| 31 | # and we cannot load perl-module-encode because we are providing |
| 32 | # an alternative |
| 33 | rm -rf ${B}/t/use-Encode-Alias.t |
| 34 | } |
| 35 | |
| 36 | do_install_ptest() { |
| 37 | mkdir ${D}${PTEST_PATH}/bin |
| 38 | cp -r ${B}/bin/piconv ${D}${PTEST_PATH}/bin |
| 39 | cp -r ${B}/blib ${D}${PTEST_PATH} |
| 40 | chown -R root:root ${D}${PTEST_PATH} |
| 41 | } |
| 42 | |
| 43 | # file /usr/bin/enc2xs from install of perl-misc-5.24.1-r0.i586 conflicts with file from package libencode-perl-2.94-r0.i586 |
| 44 | # file /usr/bin/encguess from install of perl-misc-5.24.1-r0.i586 conflicts with file from package libencode-perl-2.94-r0.i586 |
| 45 | # file /usr/bin/piconv from install of perl-misc-5.24.1-r0.i586 conflicts with file from package libencode-perl-2.94-r0.i586 |
| 46 | RCONFLICTS_${PN} = "perl-misc perl-module-encode" |
| 47 | |
| 48 | RDEPENDS_${PN} += " \ |
| 49 | perl-module-bytes \ |
| 50 | perl-module-constant \ |
| 51 | perl-module-parent \ |
| 52 | perl-module-storable \ |
| 53 | perl-module-xsloader \ |
| 54 | " |
| 55 | |
| 56 | RPROVIDES_${PN} += " \ |
| 57 | libencode-alias-perl \ |
| 58 | libencode-byte-perl \ |
| 59 | libencode-cjkconstants-perl \ |
| 60 | libencode-cn-perl \ |
| 61 | libencode-cn-hz-perl \ |
| 62 | libencode-config-perl \ |
| 63 | libencode-ebcdic-perl \ |
| 64 | libencode-encoder-perl \ |
| 65 | libencode-encoding-perl \ |
| 66 | libencode-gsm0338-perl \ |
| 67 | libencode-guess-perl \ |
| 68 | libencode-jp-perl \ |
| 69 | libencode-jp-h2z-perl \ |
| 70 | libencode-jp-jis7-perl \ |
| 71 | libencode-kr-perl \ |
| 72 | libencode-kr-2022_kr-perl \ |
| 73 | libencode-mime-header-perl \ |
| 74 | libencode-mime-name-perl \ |
| 75 | libencode-symbol-perl \ |
| 76 | libencode-tw-perl \ |
| 77 | libencode-unicode-perl \ |
| 78 | libencode-unicode-utf7-perl \ |
| 79 | libencoding-perl \ |
| 80 | libencode-internal-perl \ |
| 81 | libencode-mime-header-iso_2022_jp-perl \ |
| 82 | libencode-utf8-perl \ |
| 83 | libencode-utf_ebcdic-perl \ |
| 84 | " |
| 85 | |
| 86 | RDEPENDS_${PN}-ptest += " \ |
| 87 | perl-module-blib \ |
| 88 | perl-module-charnames \ |
| 89 | perl-module-file-compare \ |
| 90 | perl-module-file-copy \ |
| 91 | perl-module-filehandle \ |
| 92 | perl-module-findbin \ |
| 93 | perl-module-integer \ |
| 94 | perl-module-io-select \ |
| 95 | perl-module-ipc-open3 \ |
| 96 | perl-module-mime-base64 \ |
| 97 | perl-module-perlio \ |
| 98 | perl-module-perlio-encoding \ |
| 99 | perl-module-perlio-scalar \ |
| 100 | perl-module-test-more \ |
| 101 | perl-module-tie-scalar \ |
| 102 | perl-module-unicore \ |
| 103 | perl-module-utf8 \ |
| 104 | " |
| 105 | |
| 106 | BBCLASSEXTEND = "native" |