Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Framework for layout and rendering of internationalized text" |
| 2 | DESCRIPTION = "Pango is a library for laying out and rendering of text, \ |
| 3 | with an emphasis on internationalization. Pango can be used anywhere \ |
| 4 | that text layout is needed, though most of the work on Pango so far has \ |
| 5 | been done in the context of the GTK+ widget toolkit. Pango forms the \ |
| 6 | core of text and font handling for GTK+-2.x." |
| 7 | HOMEPAGE = "http://www.pango.org/" |
| 8 | BUGTRACKER = "http://bugzilla.gnome.org" |
| 9 | SECTION = "libs" |
| 10 | LICENSE = "LGPLv2.0+" |
| 11 | |
| 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7" |
| 13 | |
| 14 | GNOMEBASEBUILDCLASS = "meson" |
| 15 | |
| 16 | inherit gnomebase gtk-doc ptest-gnome upstream-version-is-even gobject-introspection |
| 17 | |
| 18 | SRC_URI += "file://run-ptest \ |
| 19 | file://0001-Fix-build-reproducibility.patch" |
| 20 | SRC_URI[archive.md5sum] = "c75cc5b833d934d98e83343832e20e5d" |
| 21 | SRC_URI[archive.sha256sum] = "66a5b6cc13db73efed67b8e933584509f8ddb7b10a8a40c3850ca4a985ea1b1f" |
| 22 | |
| 23 | DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz fribidi" |
| 24 | |
| 25 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} \ |
| 26 | ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}" |
| 27 | |
| 28 | PACKAGECONFIG[x11] = ",,virtual/libx11 libxft" |
| 29 | PACKAGECONFIG[tests] = "-Dinstall-tests=true, -Dinstall-tests=false" |
| 30 | PACKAGECONFIG[thai] = ",,libthai" |
| 31 | |
| 32 | GTKDOC_MESON_OPTION = "gtk_doc" |
| 33 | GIR_MESON_OPTION = 'introspection' |
| 34 | |
| 35 | do_configure_prepend_toolchain-clang() { |
| 36 | sed -i -e "/Werror=implicit-fallthrough/d" ${S}/meson.build |
| 37 | } |
| 38 | |
| 39 | LEAD_SONAME = "libpango-1.0*" |
| 40 | |
| 41 | FILES_${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}" |
| 42 | |
| 43 | RDEPENDS_${PN}-ptest += "cantarell-fonts" |
| 44 | RDEPENDS_${PN}-ptest_append_libc-glibc = " locale-base-en-us" |
| 45 | |
| 46 | RPROVIDES_${PN} += "pango-modules pango-module-indic-lang \ |
| 47 | pango-module-basic-fc pango-module-arabic-lang" |
| 48 | |
| 49 | BBCLASSEXTEND = "native nativesdk" |