Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Liberation(tm) Fonts" |
| 2 | DESCRIPTION = "The Liberation(tm) Fonts is a font family originally \ |
| 3 | created by Ascender(c) which aims at metric compatibility with \ |
| 4 | Arial, Times New Roman, Courier New." |
| 5 | HOMEPAGE = "https://releases.pagure.org/liberation-fonts/" |
| 6 | BUGTRACKER = "https://bugzilla.redhat.com/" |
| 7 | |
| 8 | SECTION = "x11/fonts" |
| 9 | LICENSE = "OFL-1.1" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f96db970a9a46c5369142b99f530366b" |
| 11 | PE = "1" |
| 12 | |
| 13 | inherit allarch fontcache |
| 14 | |
| 15 | FONT_PACKAGES = "${PN}" |
| 16 | |
| 17 | SRC_URI = "https://releases.pagure.org/liberation-fonts/liberation-fonts-ttf-${PV}.tar.gz \ |
| 18 | file://30-liberation-aliases.conf" |
| 19 | |
| 20 | S = "${WORKDIR}/liberation-fonts-ttf-${PV}" |
| 21 | |
| 22 | SRC_URI[md5sum] = "5c781723a0d9ed6188960defba8e91cf" |
| 23 | SRC_URI[sha256sum] = "7890278a6cd17873c57d9cd785c2d230d9abdea837e96516019c5885dd271504" |
| 24 | |
| 25 | do_install () { |
| 26 | install -d ${D}${datadir}/fonts/ttf/ |
| 27 | for i in *.ttf; do |
| 28 | install -m 0644 $i ${D}${prefix}/share/fonts/ttf/${i} |
| 29 | done |
| 30 | |
| 31 | install -d ${D}${sysconfdir}/fonts/conf.d/ |
| 32 | install -m 0644 ${WORKDIR}/30-liberation-aliases.conf ${D}${sysconfdir}/fonts/conf.d/ |
| 33 | |
| 34 | install -d ${D}${prefix}/share/doc/${BPN}/ |
| 35 | install -m 0644 LICENSE ${D}${datadir}/doc/${BPN}/ |
| 36 | } |
| 37 | |
| 38 | PACKAGES = "${PN}" |
| 39 | FILES_${PN} += "${sysconfdir} ${datadir}" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 40 | |
| 41 | BBCLASSEXTEND = "native nativesdk" |