Patrick Williams | d849ec7 | 2016-08-17 14:59:38 -0500 | [diff] [blame] | 1 | HOMEPAGE = "http://python-requests.org" |
| 2 | SUMMARY = "Python HTTP for Humans." |
| 3 | DESCRIPTION = "\ |
| 4 | Requests is an Apache2 Licensed HTTP library, written in Python, \ |
| 5 | for human beings. \ |
| 6 | . \ |
| 7 | Most existing Python modules for sending HTTP requests are extremely \ |
| 8 | verbose and cumbersome. Python's builtin urllib2 module provides most \ |
| 9 | of the HTTP capabilities you should need, but the api is thoroughly \ |
| 10 | broken. It requires an enormous amount of work (even method overrides) \ |
| 11 | to perform the simplest of tasks. \ |
| 12 | . \ |
| 13 | Things shouldn't be this way. Not in Python \ |
| 14 | " |
| 15 | SECTION = "devel/python" |
| 16 | LICENSE = "Apache-2.0" |
| 17 | LIC_FILES_CHKSUM = "file://LICENSE;md5=58c7e163c9f8ee037246da101c6afd1e" |
| 18 | |
| 19 | SRCNAME = "requests" |
| 20 | |
Brad Bishop | 6678373 | 2017-12-04 02:22:08 -0500 | [diff] [blame^] | 21 | SRC_URI = "https://pypi.python.org/packages/source/r/requests/${SRCNAME}-${PV}.tar.gz" |
Patrick Williams | d849ec7 | 2016-08-17 14:59:38 -0500 | [diff] [blame] | 22 | |
| 23 | SRC_URI[md5sum] = "a27ea3d72d7822906ddce5e252d6add9" |
| 24 | SRC_URI[sha256sum] = "84fe8d5bf4dcdcc49002446c47a146d17ac10facf00d9086659064ac43b6c25b" |
| 25 | |
| 26 | S = "${WORKDIR}/${SRCNAME}-${PV}" |
| 27 | |
| 28 | inherit setuptools |