Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "GStreamer package groups" |
| 2 | LICENSE = "MIT" |
| 3 | |
| 4 | COMMERCIAL_PLUGINS = "${COMMERCIAL_AUDIO_PLUGINS} ${COMMERCIAL_VIDEO_PLUGINS}" |
| 5 | DEPENDS_UGLY="${@'gst-plugins-ugly' if 'ugly' in COMMERCIAL_PLUGINS.split('-') else ''}" |
| 6 | DEPENDS_BAD="${@'gst-plugins-bad' if 'bad' in COMMERCIAL_PLUGINS.split('-') else ''}" |
| 7 | DEPENDS = "gstreamer gst-plugins-base gst-plugins-good ${DEPENDS_UGLY} ${DEPENDS_BAD}" |
| 8 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 9 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302 \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 10 | file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" |
| 11 | |
| 12 | |
| 13 | PR = "r13" |
| 14 | |
| 15 | PACKAGES = "\ |
| 16 | gst-meta-base \ |
| 17 | gst-meta-x11-base \ |
| 18 | gst-meta-audio \ |
| 19 | gst-meta-debug \ |
| 20 | gst-meta-video" |
| 21 | |
| 22 | ALLOW_EMPTY_gst-meta-base = "1" |
| 23 | ALLOW_EMPTY_gst-meta-x11-base = "1" |
| 24 | ALLOW_EMPTY_gst-meta-audio = "1" |
| 25 | ALLOW_EMPTY_gst-meta-debug = "1" |
| 26 | ALLOW_EMPTY_gst-meta-video = "1" |
| 27 | |
| 28 | RDEPENDS_gst-meta-base = "\ |
| 29 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gst-meta-x11-base', '', d)} \ |
| 30 | gstreamer \ |
| 31 | gst-plugins-base-playbin \ |
| 32 | gst-plugins-base-decodebin \ |
| 33 | gst-plugins-base-decodebin2 \ |
| 34 | gst-plugins-base-gio \ |
| 35 | gst-plugins-base-alsa \ |
| 36 | gst-plugins-base-volume \ |
| 37 | gst-plugins-base-audioconvert \ |
| 38 | gst-plugins-base-audioresample \ |
| 39 | gst-plugins-base-typefindfunctions \ |
| 40 | gst-plugins-base-videoscale \ |
| 41 | gst-plugins-base-ffmpegcolorspace \ |
| 42 | gst-plugins-good-autodetect \ |
| 43 | gst-plugins-good-souphttpsrc" |
| 44 | |
| 45 | RRECOMMENDS_gst-meta-x11-base = "\ |
| 46 | gst-plugins-base-ximagesink \ |
| 47 | gst-plugins-base-xvimagesink" |
| 48 | |
| 49 | RDEPENDS_gst-meta-audio = "\ |
| 50 | gst-meta-base \ |
| 51 | gst-plugins-base-vorbis \ |
| 52 | gst-plugins-base-ogg \ |
| 53 | gst-plugins-good-wavparse \ |
| 54 | gst-plugins-good-flac \ |
| 55 | ${COMMERCIAL_AUDIO_PLUGINS}" |
| 56 | |
| 57 | |
| 58 | RDEPENDS_gst-meta-debug = "\ |
| 59 | gst-meta-base \ |
| 60 | gst-plugins-good-debug \ |
| 61 | gst-plugins-base-audiotestsrc \ |
| 62 | gst-plugins-base-videotestsrc" |
| 63 | |
| 64 | |
| 65 | RDEPENDS_gst-meta-video = "\ |
| 66 | gst-meta-base \ |
| 67 | gst-plugins-good-avi \ |
| 68 | gst-plugins-good-matroska \ |
| 69 | gst-plugins-base-theora \ |
| 70 | ${COMMERCIAL_VIDEO_PLUGINS}" |
| 71 | |
| 72 | RRECOMMENDS_gst-meta-video = "\ |
| 73 | gst-meta-audio" |