Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | require gst-plugins.inc |
| 2 | |
| 3 | LICENSE = "GPLv2+ & LGPLv2+ & LGPLv2.1+ " |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \ |
| 5 | file://gst/tta/filters.h;beginline=12;endline=29;md5=629b0c7a665d155a6677778f4460ec06 \ |
| 6 | file://COPYING.LIB;md5=55ca817ccb7d5b5b66355690e9abc605 \ |
| 7 | file://gst/tta/crc32.h;beginline=12;endline=29;md5=71a904d99ce7ae0c1cf129891b98145c" |
| 8 | |
| 9 | DEPENDS += "gst-plugins-base" |
| 10 | |
| 11 | PR = "r4" |
| 12 | |
| 13 | SRC_URI += "file://buffer-overflow-mp4.patch" |
| 14 | |
| 15 | inherit gettext gsettings |
| 16 | |
| 17 | EXTRA_OECONF += "--disable-experimental \ |
| 18 | --disable-sdl --disable-cdaudio --disable-directfb \ |
| 19 | --disable-vdpau --disable-apexsink" |
| 20 | |
| 21 | PACKAGECONFIG ??= "bzip curl \ |
| 22 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'rsvg', '', d)}" |
| 23 | |
| 24 | PACKAGECONFIG[bzip] = "--enable-bz2,--disable-bz2,bzip2" |
| 25 | PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl" |
| 26 | PACKAGECONFIG[rsvg] = "--enable-rsvg,--disable-rsvg,librsvg," |
| 27 | PACKAGECONFIG[orc] = "--enable-orc,--disable-orc,orc" |
| 28 | PACKAGECONFIG[neon] = "--enable-neon,--disable-neon,neon" |
| 29 | PACKAGECONFIG[mms] = "--enable-libmms,--disable-libmms,libmms" |
| 30 | PACKAGECONFIG[cog] = "--enable-cog,--disable-cog,libpng" |
| 31 | PACKAGECONFIG[faad] = "--enable-faad,--disable-faad,faad2" |
| 32 | PACKAGECONFIG[jp2k] = "--enable-jp2k,--disable-jp2k,jasper" |
| 33 | PACKAGECONFIG[modplug] = "--enable-modplug,--disable-modplug,libmodplug" |
| 34 | PACKAGECONFIG[opus] = "--enable-opus,--disable-opus,libopus" |
| 35 | PACKAGECONFIG[sndfile] = "--enable-sndfile,--disable-sndfile,libsndfile1" |
| 36 | PACKAGECONFIG[vp8] = "--enable-vp8,--disable-vp8,libvpx" |
| 37 | PACKAGECONFIG[ass] = "--enable-assrender,--disable-assrender,libass" |
| 38 | PACKAGECONFIG[openal] = "--enable-openal,--disable-openal,openal-soft" |
| 39 | PACKAGECONFIG[schro] = "--enable-schro,--disable-schro,schroedinger" |
| 40 | PACKAGECONFIG[dc1394] = "--enable-dc1394,--disable-dc1394,libdc1394" |
| 41 | PACKAGECONFIG[faac] = "--enable-faac,--disable-faac,faac" |
| 42 | PACKAGECONFIG[rtmp] = "--enable-rtmp,--disable-rtmp,rtmpdump" |
| 43 | PACKAGECONFIG[voamrwbenc] = "--enable-voamrwbenc,--disable-voamrwbenc,vo-amrwbenc" |
| 44 | PACKAGECONFIG[voaacenc] = "--enable-voaacenc,--disable-voaacenc,vo-aacenc" |
| 45 | PACKAGECONFIG[resindvd] = "--enable-resindvd,--disable-resindvd,libdvdnav libdvdread" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 46 | PACKAGECONFIG[zbar] = "--enable-zbar,--disable-zbar,zbar jpeg" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 47 | |
| 48 | ARM_INSTRUCTION_SET = "arm" |
| 49 | |
| 50 | PACKAGES =+ "${PN}-resindvd" |
| 51 | FILES_${PN}-resindvd = "${libdir}/gstreamer-${LIBV}/libresindvd.so" |
| 52 | FILES_${PN}-dev += "${libdir}/gstreamer-${LIBV}/libresindvd.la" |
| 53 | FILES_${PN}-voamrwbenc += "${datadir}/gstreamer-${LIBV}/presets/GstVoAmrwbEnc.prs" |
| 54 | |
| 55 | do_configure_prepend() { |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 56 | # This m4 file contains nastiness which conflicts with libtool 2.2.2 |
| 57 | rm ${S}/m4/lib-link.m4 || true |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 58 | } |
| 59 | |
| 60 | SRC_URI[md5sum] = "fcb09798114461955260e4d940db5987" |
| 61 | SRC_URI[sha256sum] = "0eae7d1a1357ae8377fded6a1b42e663887beabe0e6cc336e2ef9ada42e11491" |