Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "An implementation of the standard Unix documentation system accessed using the man command" |
| 2 | HOMEPAGE = "http://man-db.nongnu.org/" |
| 3 | LICENSE = "LGPLv2.1 & GPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://docs/COPYING.LIB;md5=a6f89e2100d9b6cdffcea4f398e37343 \ |
| 5 | file://docs/COPYING;md5=eb723b61539feef013de476e68b5c50a" |
| 6 | |
| 7 | SRC_URI = "${SAVANNAH_NONGNU_MIRROR}/man-db/man-db-${PV}.tar.xz \ |
| 8 | file://99_mandb \ |
| 9 | file://man_db.conf-avoid-multilib-install-file-conflict.patch" |
Andrew Geissler | d25ed32 | 2020-06-27 00:28:28 -0500 | [diff] [blame] | 10 | SRC_URI[sha256sum] = "fa5aa11ab0692daf737e76947f45669225db310b2801a5911bceb7551c5597b8" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 11 | |
| 12 | DEPENDS = "libpipeline gdbm groff-native base-passwd" |
| 13 | RDEPENDS_${PN} += "base-passwd" |
Andrew Geissler | c723b72 | 2021-01-08 16:14:09 -0600 | [diff] [blame] | 14 | PACKAGE_WRITE_DEPS += "base-passwd" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 15 | |
| 16 | # | /usr/src/debug/man-db/2.8.0-r0/man-db-2.8.0/src/whatis.c:939: undefined reference to `_nl_msg_cat_cntr' |
| 17 | USE_NLS_libc-musl = "no" |
| 18 | |
| 19 | inherit gettext pkgconfig autotools systemd |
| 20 | |
| 21 | EXTRA_OECONF = "--with-pager=less --with-systemdsystemunitdir=${systemd_unitdir}/system" |
| 22 | EXTRA_AUTORECONF += "-I ${S}/gl/m4" |
| 23 | |
Andrew Geissler | c723b72 | 2021-01-08 16:14:09 -0600 | [diff] [blame] | 24 | # Can be dropped when the output next changes, avoids failures after |
| 25 | # reproducibility issues |
| 26 | PR = "r1" |
| 27 | HASHEQUIV_HASH_VERSION .= ".1" |
| 28 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 29 | do_install() { |
| 30 | autotools_do_install |
| 31 | |
| 32 | if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then |
| 33 | install -d ${D}/etc/default/volatiles |
| 34 | install -m 0644 ${WORKDIR}/99_mandb ${D}/etc/default/volatiles |
| 35 | fi |
| 36 | } |
| 37 | |
| 38 | do_install_append_libc-musl() { |
| 39 | rm -f ${D}${libdir}/charset.alias |
| 40 | } |
| 41 | |
| 42 | FILES_${PN} += "${prefix}/lib/tmpfiles.d" |
| 43 | |
| 44 | FILES_${PN}-dev += "${libdir}/man-db/libman.so ${libdir}/${BPN}/libmandb.so" |
| 45 | |
| 46 | RDEPENDS_${PN} += "groff" |
| 47 | RRECOMMENDS_${PN} += "less" |
| 48 | RPROVIDES_${PN} += " man" |
| 49 | |
| 50 | def compress_pkg(d): |
| 51 | if bb.utils.contains("INHERIT", "compress_doc", True, False, d): |
| 52 | compress = d.getVar("DOC_COMPRESS") |
| 53 | if compress == "gz": |
| 54 | return "gzip" |
| 55 | elif compress == "bz2": |
| 56 | return "bzip2" |
| 57 | elif compress == "xz": |
| 58 | return "xz" |
| 59 | return "" |
| 60 | |
| 61 | RDEPENDS_${PN} += "${@compress_pkg(d)}" |
| 62 | |
| 63 | SYSTEMD_SERVICE_${PN} = "man-db.timer man-db.service" |
| 64 | SYSTEMD_AUTO_ENABLE ?= "disable" |