blob: 8e9e8cc02f3581ba4549d25b5e242b5b42606dc5 [file] [log] [blame]
Andrew Geissler69721092021-07-23 12:57:00 -04001SUMMARY = "YANG data modeling language library"
2DESCRIPTION = "libyang is a YANG data modelling language parser and toolkit written (and providing API) in C."
3HOMEPAGE = "https://github.com/CESNET/libyang"
4SECTION = "libs"
5LICENSE = "BSD-3-Clause"
6
7LIC_FILES_CHKSUM = "file://LICENSE;md5=f3916d7d8d42a6508d0ea418cfff10ad"
8
9SRCREV = "69d9fff65abb58beb0bb6aa9ecacd572ca1dfc56"
10
11SRC_URI = "git://github.com/CESNET/libyang.git \
12 file://libyang-skip-pcre2-config-add-stdint-h.patch \
13 file://run-ptest \
14 "
15
16S = "${WORKDIR}/git"
17
18COMPATIBLE_HOST_riscv32 = "null"
19COMPATIBLE_HOST_armv5 = "null"
20COMPATIBLE_HOST_riscv64 = "null"
21
22# Main dependencies
23inherit cmake pkgconfig lib_package binconfig-disabled ptest
24DEPENDS = "libpcre2"
25DEPENDS += "${@bb.utils.contains('PTEST_ENABLED', '1', 'cmocka', '', d)}"
26BINCONFIG = "${bindir}/pcre2-config"
27
28# Ptest dependencies
29RDEPENDS_${PN}-ptest += "valgrind"
30
31EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release"
32EXTRA_OECMAKE += " ${@bb.utils.contains('PTEST_ENABLED', '1', '-DENABLE_BUILD_TESTS=ON', '', d)}"
33
34do_install_ptest () {
35 cp -fR ${B}/tests/ ${D}${PTEST_PATH}/
36}
37