Andrew Geissler | e34f896 | 2021-04-15 15:53:51 -0500 | [diff] [blame] | 1 | SUMMARY = "the Apache Kafka C/C++ client library" |
| 2 | DESCRIPTION = "librdkafka is a C library implementation of the Apache Kafka protocol, providing Producer, Consumer and Admin clients." |
| 3 | HOMEPAGE = "https://github.com/edenhill/librdkafka" |
| 4 | SECTION = "libs" |
| 5 | LICENSE = "BSD-2-Clause" |
| 6 | |
| 7 | LIC_FILES_CHKSUM = " \ |
| 8 | file://LICENSE;md5=2be8675acbfdac48935e73897af5f646 \ |
| 9 | " |
| 10 | |
| 11 | SRC_URI = "git://github.com/edenhill/librdkafka;protocol=https \ |
| 12 | file://0001_fix_absolute_path_usage.patch" |
| 13 | SRCREV = "1a722553638bba85dbda5050455f7b9a5ef302de" |
| 14 | |
| 15 | DEPENDS = "zlib openssl zstd" |
| 16 | |
| 17 | inherit cmake |
| 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | FILES_${PN} += "${datadir}" |
| 22 | |
| 23 | EXTRA_OECMAKE += "-DRDKAFKA_BUILD_EXAMPLES=OFF -DRDKAFKA_BUILD_TESTS=OFF" |