Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Protocol Buffers" |
| 2 | HOMEPAGE = "https://developers.google.com/protocol-buffers/" |
| 3 | SECTION = "devel/python" |
| 4 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 5 | LICENSE = "BSD-3-Clause" |
Brad Bishop | 0f291cc | 2019-09-01 15:16:57 -0400 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=19e8f490f9526b1de84f8d949cfcfd4e" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 7 | |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 8 | inherit pypi setuptools3 |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 9 | |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame^] | 10 | SRC_URI[sha256sum] = "72804ea5eaa9c22a090d2803813e280fb273b62d5ae497aaf3553d141c4fdd7b" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 11 | |
| 12 | # http://errors.yoctoproject.org/Errors/Details/184715/ |
| 13 | # Can't find required file: ../src/google/protobuf/descriptor.proto |
| 14 | CLEANBROKEN = "1" |
| 15 | |
| 16 | UPSTREAM_CHECK_REGEX = "protobuf/(?P<pver>\d+(\.\d+)+)/" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 17 | |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 18 | DEPENDS += "protobuf" |
| 19 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 20 | RDEPENDS_${PN} += " \ |
| 21 | ${PYTHON_PN}-datetime \ |
| 22 | ${PYTHON_PN}-json \ |
| 23 | ${PYTHON_PN}-logging \ |
| 24 | ${PYTHON_PN}-netclient \ |
| 25 | ${PYTHON_PN}-numbers \ |
| 26 | ${PYTHON_PN}-pkgutil \ |
| 27 | ${PYTHON_PN}-six \ |
| 28 | ${PYTHON_PN}-unittest \ |
| 29 | " |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 30 | |
| 31 | # For usage in other recipies when compiling protobuf files (e.g. by grpcio-tools) |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 32 | BBCLASSEXTEND = "native nativesdk" |
| 33 | |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 34 | DISTUTILS_BUILD_ARGS += "--cpp_implementation" |
| 35 | DISTUTILS_INSTALL_ARGS += "--cpp_implementation" |
| 36 | |
| 37 | do_compile_prepend_class-native () { |
| 38 | export KOKORO_BUILD_NUMBER="1" |
| 39 | } |