blob: 17fbbae25bc497306db0f09080f11b82a7a8bab2 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001DESCRIPTION = "lib-curses provides an interface between Perl programs and \
2the curses library."
3
4SECTION = "libs"
5LICENSE = "Artistic-1.0 | GPL-1.0+"
6
7LIC_FILES_CHKSUM = "file://README;beginline=26;endline=30;md5=0b37356c5e9e28080a3422d82af8af09"
8
9DEPENDS += "perl ncurses "
10
11SRC_URI = "http://www.cpan.org/authors/id/G/GI/GIRAFFED/Curses-${PV}.tar.gz"
12
Andrew Geisslerbbbd5f42020-10-30 15:42:48 -050013SRC_URI[md5sum] = "aede9d1ed9856eff89f4ce208ee59de0"
14SRC_URI[sha256sum] = "74707ae3ad19b35bbefda2b1d6bd31f57b40cdac8ab872171c8714c88954db20"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050015
16S = "${WORKDIR}/Curses-${PV}"
17
18EXTRA_CPANFLAGS = "INC=-I${STAGING_INCDIR} LIBS=-L${STAGING_LIBDIR}"
19
20inherit cpan
21
22do_compile() {
23 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
24 cpan_do_compile
25}
26