blob: d4ac4096bcb77935a9bd969d6a7bf6e3232932d8 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Mycroft is a hackable open source voice assistant."
2DESCRIPTION = "Mycroft is the world’s first open source assistant. "
3HOMEPAGE = "https://mycroft.ai/"
4SECTION = "multimedia"
5
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=79aa497b11564d1d419ee889e7b498f6"
8
Brad Bishop6a62e0e2019-10-21 08:11:42 -04009SRCREV = "913f29d3d550637934f9abf43a097eb2c30d76fc"
Brad Bishopc342db32019-05-15 21:57:59 -040010SRC_URI = "git://github.com/MycroftAI/mycroft-core.git;branch=master \
11 file://0001-Remove-python-venv.patch \
Brad Bishop6a62e0e2019-10-21 08:11:42 -040012 file://0002-dev_setup.sh-Remove-the-git-dependency.patch \
13 file://0003-dev_setup.sh-Remove-the-TERM-dependency.patch \
14 file://0004-pip-requirements-Don-t-install-requirements-with-pip.patch \
15 file://0005-Use-python3-and-pip3-instead-of-python-and-pip.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040016 file://dev_opts.json \
17 file://mycroft-setup.service \
18 file://mycroft.service \
19 "
20
21S = "${WORKDIR}/git"
22
23inherit systemd
24
25# Mycroft installs itself on the host
26# Just copy the setup files to the rootfs
Brad Bishop6a62e0e2019-10-21 08:11:42 -040027# The mycroft-setup service will copy the files to /var/ where we run them from
Brad Bishopc342db32019-05-15 21:57:59 -040028do_install() {
29 install -d ${D}${libdir}/
30 cp -r ${B} ${D}${libdir}/mycroft
31 rm -r ${D}${libdir}/mycroft/.git
32
33 # Install the dev opts so it doesn't ask us on initial setup.
34 install -m 644 ${WORKDIR}/dev_opts.json ${D}${libdir}/mycroft/.dev_opts.json
35
36 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
37 install -d ${D}${systemd_unitdir}/system
38 install -m 644 ${WORKDIR}/mycroft-setup.service ${D}${systemd_unitdir}/system
39 sed -i -e 's,@LIBDIR@,${libdir},g' ${D}${systemd_unitdir}/system/mycroft-setup.service
40 fi
41
42 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
43 install -d ${D}${systemd_unitdir}/system
44 install -m 644 ${WORKDIR}/mycroft.service ${D}${systemd_unitdir}/system
45 sed -i -e 's,@LIBDIR@,${libdir},g' ${D}${systemd_unitdir}/system/mycroft.service
46 fi
47}
48
49FILES_${PN} += "${libdir}/mycroft"
50
51RDEPENDS_${PN} = "python3"
52
Brad Bishop6a62e0e2019-10-21 08:11:42 -040053RDEPENDS_${PN} += "python3-requests python3-pillow \
Brad Bishopc342db32019-05-15 21:57:59 -040054 python3-tornado python3-pyyaml \
55 python3-pyalsaaudio python3-inflection \
56 python3-pyserial python3-psutil \
57 python3-pyaudio python3-fann2 \
58 python3-pocketsphinx \
Brad Bishop6a62e0e2019-10-21 08:11:42 -040059 python3-xxhash python3-pako \
60 python3-six python3-cryptography \
61 python3-requests-futures \
62 python3-xmlrunner python3-fasteners \
63 python3-python-vlc \
64 python3-padatious python3-padaos \
65 python3-petact python3-precise-runner \
66 python3-pulsectl python3-pychromecast \
67 python3-msm python3-msk \
68 python3-websocket-client \
69 python3-google-api-python-client \
Brad Bishopc342db32019-05-15 21:57:59 -040070 "
71
Brad Bishop6a62e0e2019-10-21 08:11:42 -040072# These packages need to be installed on the target
73# python3-speechrecognition python3-pyee==5.0.0 python3-six==1.10.0
74# python3-websocket-client==0.54.0 python3-gtts python3-gtts-token
75# python3-python-dateutil python3-adapt-parser python3-lazy
76
Brad Bishopc342db32019-05-15 21:57:59 -040077# Mycroft uses Alsa, PulseAudio and Flac
Brad Bishop7e36d532019-09-16 07:44:26 -040078RDEPENDS_${PN} += "alsa-utils alsa-plugins alsa-tools"
Brad Bishopc342db32019-05-15 21:57:59 -040079RDEPENDS_${PN} += "pulseaudio pulseaudio-misc pulseaudio-server"
80RDEPENDS_${PN} += "flac"
81
82# Mycroft can do this itself on the target, but it's quicker to do it here
83RDEPENDS_${PN} += "mimic"
84
85SYSTEMD_SERVICE_${PN} = "mycroft-setup.service mycroft.service"