blob: f9e44421dfa7190b11813114eac35cc3eea1b661 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Rsyslog is an enhanced multi-threaded syslogd"
2DESCRIPTION = "\
3Rsyslog is an enhanced syslogd supporting, among others, MySQL,\
4 PostgreSQL, failover log destinations, syslog/tcp, fine grain\
5 output format control, high precision timestamps, queued operations\
6 and the ability to filter on any message part. It is quite\
7 compatible to stock sysklogd and can be used as a drop-in replacement.\
8 Its advanced features make it suitable for enterprise-class,\
9 encryption protected syslog relay chains while at the same time being\
10 very easy to setup for the novice user."
11
12DEPENDS = "zlib libestr libfastjson bison-native flex-native liblogging"
13HOMEPAGE = "http://www.rsyslog.com/"
14LICENSE = "GPLv3 & LGPLv3 & Apache-2.0"
15LIC_FILES_CHKSUM = "file://COPYING;md5=51d9635e646fb75e1b74c074f788e973 \
16 file://COPYING.LESSER;md5=cb7903f1e5c39ae838209e130dca270a \
17 file://COPYING.ASL20;md5=052f8a09206615ab07326ff8ce2d9d32\
18"
19
20SRC_URI = "http://www.rsyslog.com/download/files/download/rsyslog/${BPN}-${PV}.tar.gz \
21 file://initscript \
22 file://rsyslog.conf \
23 file://rsyslog.logrotate \
24 file://use-pkgconfig-to-check-libgcrypt.patch \
25 file://run-ptest \
Brad Bishop00ab2372019-10-14 11:06:18 -040026 file://0001-Out-of-bounds-issue.patch \
Brad Bishop6a62e0e2019-10-21 08:11:42 -040027 file://0001-pmaixforwardedfrom-bugfix-potential-misadressing.patch \
Brad Bishop19323692019-04-05 15:28:33 -040028"
29
30SRC_URI_append_libc-musl = " \
31 file://0001-Include-sys-time-h.patch \
32"
33
Brad Bishop0a921262019-09-24 07:40:45 -040034SRC_URI[md5sum] = "6e9aa4ef4cad8ae49affa0a786cc9e2f"
35SRC_URI[sha256sum] = "f8c8e53b651e03a011667c60bd2d4dba7a7cb6ec04b247c8ea8514115527863b"
Brad Bishop19323692019-04-05 15:28:33 -040036
37UPSTREAM_CHECK_URI = "https://github.com/rsyslog/rsyslog/releases"
38UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)"
39
40inherit autotools pkgconfig systemd update-rc.d ptest
41
42EXTRA_OECONF += "--disable-generate-man-pages ap_cv_atomic_builtins=yes"
Brad Bishop0a921262019-09-24 07:40:45 -040043EXTRA_OECONF += "--enable-imfile-tests"
Brad Bishop19323692019-04-05 15:28:33 -040044
45# first line is default yes in configure
46PACKAGECONFIG ??= " \
47 rsyslogd rsyslogrt klog inet regexp uuid libgcrypt \
48 fmhttp imdiag gnutls imfile \
49 ${@bb.utils.filter('DISTRO_FEATURES', 'snmp systemd', d)} \
50 ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'testbench relp ${VALGRIND}', '', d)} \
51"
52
53# default yes in configure
54PACKAGECONFIG[relp] = "--enable-relp,--disable-relp,librelp,"
55PACKAGECONFIG[rsyslogd] = "--enable-rsyslogd,--disable-rsyslogd,,"
56PACKAGECONFIG[rsyslogrt] = "--enable-rsyslogrt,--disable-rsyslogrt,,"
57PACKAGECONFIG[fmhttp] = "--enable-fmhttp,--disable-fmhttp,curl,"
58PACKAGECONFIG[inet] = "--enable-inet,--disable-inet,,"
59PACKAGECONFIG[klog] = "--enable-klog,--disable-klog,,"
60PACKAGECONFIG[regexp] = "--enable-regexp,--disable-regexp,,"
61PACKAGECONFIG[uuid] = "--enable-uuid,--disable-uuid,util-linux,"
62PACKAGECONFIG[libgcrypt] = "--enable-libgcrypt,--disable-libgcrypt,libgcrypt,"
63PACKAGECONFIG[testbench] = "--enable-testbench --enable-omstdout,--disable-testbench --disable-omstdout,,"
64
65# default no in configure
66PACKAGECONFIG[debug] = "--enable-debug,--disable-debug,,"
67PACKAGECONFIG[imdiag] = "--enable-imdiag,--disable-imdiag,,"
68PACKAGECONFIG[imfile] = "--enable-imfile,--disable-imfile,,"
69PACKAGECONFIG[snmp] = "--enable-snmp,--disable-snmp,net-snmp,"
70PACKAGECONFIG[gnutls] = "--enable-gnutls,--disable-gnutls,gnutls,"
71PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,--without-systemdsystemunitdir,systemd,"
72PACKAGECONFIG[imjournal] = "--enable-imjournal,--disable-imjournal,"
Brad Bishop34ae6002019-04-08 15:21:03 -040073PACKAGECONFIG[mmjsonparse] = "--enable-mmjsonparse,--disable-mmjsonparse,"
Brad Bishop19323692019-04-05 15:28:33 -040074PACKAGECONFIG[mysql] = "--enable-mysql,--disable-mysql,mysql5,"
75PACKAGECONFIG[postgresql] = "--enable-pgsql,--disable-pgsql,postgresql,"
76PACKAGECONFIG[libdbi] = "--enable-libdbi,--disable-libdbi,libdbi,"
77PACKAGECONFIG[mail] = "--enable-mail,--disable-mail,,"
78PACKAGECONFIG[valgrind] = "--enable-valgrind,--disable-valgrind,valgrind,"
79
80TESTDIR = "tests"
81do_compile_ptest() {
82 echo 'buildtest-TESTS: $(check_PROGRAMS)' >> ${TESTDIR}/Makefile
83 oe_runmake -C ${TESTDIR} buildtest-TESTS
84}
85
86do_install_ptest() {
87 # install the tests
88 cp -rf ${S}/${TESTDIR} ${D}${PTEST_PATH}
89 cp -rf ${B}/${TESTDIR} ${D}${PTEST_PATH}
90
91 # do NOT need to rebuild Makefile itself
92 sed -i 's/^Makefile:.*$/Makefile:/' ${D}${PTEST_PATH}/${TESTDIR}/Makefile
93 # do NOT need to rebuild $(check_PROGRAMS)
94 sed -i 's/^check-TESTS:.*$/check-TESTS:/' ${D}${PTEST_PATH}/${TESTDIR}/Makefile
95
96 # fix the srcdir, top_srcdir
97 sed -i 's,^\(srcdir = \).*,\1${PTEST_PATH}/tests,' ${D}${PTEST_PATH}/${TESTDIR}/Makefile
98 sed -i 's,^\(top_srcdir = \).*,\1${PTEST_PATH}/tests,' ${D}${PTEST_PATH}/${TESTDIR}/Makefile
99 # fix the abs_top_builddir
100 sed -i 's,^\(abs_top_builddir = \).*,\1${PTEST_PATH}/,' ${D}${PTEST_PATH}/${TESTDIR}/Makefile
101
102 # valgrind is not compatible with arm and mips,
103 # so remove related test cases if there is no valgrind.
104 if [ x${VALGRIND} = x ]; then
105 sed -i '/udp-msgreduc-/d' ${D}${PTEST_PATH}/${TESTDIR}/Makefile
106 fi
107
108 # install test-driver
109 install -m 644 ${S}/test-driver ${D}${PTEST_PATH}
110
111 # install necessary links
112 install -d ${D}${PTEST_PATH}/tools
113 ln -sf ${sbindir}/rsyslogd ${D}${PTEST_PATH}/tools/rsyslogd
114
115 install -d ${D}${PTEST_PATH}/runtime
116 install -d ${D}${PTEST_PATH}/runtime/.libs
117 (
118 cd ${D}/${libdir}/rsyslog
119 allso="*.so"
120 for i in $allso; do
121 ln -sf ${libdir}/rsyslog/$i ${D}${PTEST_PATH}/runtime/.libs/$i
122 done
123 )
124
125 # fix the module load path with runtime/.libs
126 find ${D}${PTEST_PATH}/${TESTDIR} -name "*.conf" -o -name "*.sh" -o -name "*.c" | xargs \
127 sed -i -e 's:../plugins/.*/.libs/:../runtime/.libs/:g'
128}
129
130do_install_append() {
131 install -d "${D}${sysconfdir}/init.d"
132 install -d "${D}${sysconfdir}/logrotate.d"
133 install -m 755 ${WORKDIR}/initscript ${D}${sysconfdir}/init.d/syslog
134 install -m 644 ${WORKDIR}/rsyslog.conf ${D}${sysconfdir}/rsyslog.conf
135 install -m 644 ${WORKDIR}/rsyslog.logrotate ${D}${sysconfdir}/logrotate.d/logrotate.rsyslog
136 sed -i -e "s#@BINDIR@#${bindir}#g" ${D}${sysconfdir}/logrotate.d/logrotate.rsyslog
137
138 if ${@bb.utils.contains('PACKAGECONFIG', 'imjournal', 'true', 'false', d)}; then
139 install -d 0755 ${D}${sysconfdir}/rsyslog.d
140 echo '$ModLoad imjournal' >> ${D}${sysconfdir}/rsyslog.d/imjournal.conf
141 fi
Brad Bishop34ae6002019-04-08 15:21:03 -0400142 if ${@bb.utils.contains('PACKAGECONFIG', 'mmjsonparse', 'true', 'false', d)}; then
143 install -d 0755 ${D}${sysconfdir}/rsyslog.d
144 echo '$ModLoad mmjsonparse' >> ${D}${sysconfdir}/rsyslog.d/mmjsonparse.conf
145 fi
Brad Bishop19323692019-04-05 15:28:33 -0400146}
147
148FILES_${PN} += "${bindir}"
149
150INITSCRIPT_NAME = "syslog"
151INITSCRIPT_PARAMS = "defaults"
152
153CONFFILES_${PN} = "${sysconfdir}/rsyslog.conf"
154
155RCONFLICTS_${PN} = "busybox-syslog sysklogd syslog-ng"
156
157RPROVIDES_${PN} += "${PN}-systemd"
158RREPLACES_${PN} += "${PN}-systemd"
159RCONFLICTS_${PN} += "${PN}-systemd"
160SYSTEMD_SERVICE_${PN} = "${BPN}.service"
161
162RDEPENDS_${PN} += "logrotate"
163
164# for rsyslog-ptest
165VALGRIND = "valgrind"
166VALGRIND_mips = ""
167VALGRIND_mips64 = ""
168VALGRIND_mips64n32 = ""
169VALGRIND_arm = ""
170VALGRIND_aarch64 = ""
171VALGRIND_riscv64 = ""
172RDEPENDS_${PN}-ptest += "\
173 make diffutils gzip bash gawk coreutils procps \
174 libgcc python-core python-io \
175 "
176RRECOMMENDS_${PN}-ptest += "${TCLIBC}-dbg ${VALGRIND}"