Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Liberation(tm) Fonts" |
| 2 | DESCRIPTION = "The Liberation(tm) Fonts is a font family originally \ |
| 3 | created by Ascender(c) which aims at metric compatibility with \ |
| 4 | Arial, Times New Roman, Courier New." |
| 5 | HOMEPAGE = "https://fedorahosted.org/liberation-fonts/" |
| 6 | BUGTRACKER = "https://bugzilla.redhat.com/" |
| 7 | |
| 8 | RECIPE_NO_UPDATE_REASON = "2.x depends on fontforge package, which is not yet provided in oe-core" |
| 9 | |
| 10 | SECTION = "x11/fonts" |
| 11 | LICENSE = "GPLv2" |
| 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
| 13 | PR = "r4" |
| 14 | PE = "1" |
| 15 | |
| 16 | inherit allarch fontcache |
| 17 | |
| 18 | FONT_PACKAGES = "${PN}" |
| 19 | |
| 20 | SRC_URI = "https://fedorahosted.org/releases/l/i/liberation-fonts/liberation-fonts-${PV}.tar.gz \ |
| 21 | file://30-liberation-aliases.conf" |
| 22 | |
| 23 | SRC_URI[md5sum] = "4846797ef0fc70b0cbaede2514677c58" |
| 24 | SRC_URI[sha256sum] = "0e0d0957c85b758561a3d4aef4ebcd2c39959e5328429d96ae106249d83531a1" |
| 25 | |
| 26 | do_install () { |
| 27 | install -d ${D}${datadir}/fonts/ttf/ |
| 28 | for i in *.ttf; do |
| 29 | install -m 0644 $i ${D}${prefix}/share/fonts/ttf/${i} |
| 30 | done |
| 31 | |
| 32 | install -d ${D}${sysconfdir}/fonts/conf.d/ |
| 33 | install -m 0644 ${WORKDIR}/30-liberation-aliases.conf ${D}${sysconfdir}/fonts/conf.d/ |
| 34 | |
| 35 | install -d ${D}${prefix}/share/doc/${BPN}/ |
| 36 | install -m 0644 License.txt ${D}${datadir}/doc/${BPN}/ |
| 37 | } |
| 38 | |
| 39 | PACKAGES = "${PN}" |
| 40 | FILES_${PN} += "${sysconfdir} ${datadir}" |