Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | # This recipe is for bootstrapping our go-cross from a prebuilt binary of Go from golang.org. |
| 2 | |
| 3 | SUMMARY = "Go programming language compiler (upstream binary for bootstrap)" |
| 4 | HOMEPAGE = " http://golang.org/" |
| 5 | LICENSE = "BSD-3-Clause" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=5d4950ecb7b26d2c5e4e7b4e0dd74707" |
| 7 | |
| 8 | PROVIDES = "go-native" |
| 9 | |
| 10 | # Checksums available at https://go.dev/dl/ |
| 11 | SRC_URI = "https://dl.google.com/go/go${PV}.${BUILD_GOOS}-${BUILD_GOARCH}.tar.gz;name=go_${BUILD_GOTUPLE}" |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame^] | 12 | SRC_URI[go_linux_amd64.sha256sum] = "000a5b1fca4f75895f78befeb2eecf10bfff3c428597f3f1e69133b63b911b02" |
| 13 | SRC_URI[go_linux_arm64.sha256sum] = "5e5e2926733595e6f3c5b5ad1089afac11c1490351855e87849d0e7702b1ec2e" |
| 14 | SRC_URI[go_linux_ppc64le.sha256sum] = "85cfd4b89b48c94030783b6e9e619e35557862358b846064636361421d0b0c52" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 15 | |
| 16 | UPSTREAM_CHECK_URI = "https://golang.org/dl/" |
| 17 | UPSTREAM_CHECK_REGEX = "go(?P<pver>\d+(\.\d+)+)\.linux" |
| 18 | |
| 19 | S = "${WORKDIR}/go" |
| 20 | |
| 21 | inherit goarch native |
| 22 | |
| 23 | do_compile() { |
| 24 | : |
| 25 | } |
| 26 | |
| 27 | make_wrapper() { |
| 28 | rm -f ${D}${bindir}/$1 |
| 29 | cat <<END >${D}${bindir}/$1 |
| 30 | #!/bin/bash |
| 31 | here=\`dirname \$0\` |
| 32 | export GOROOT="${GOROOT:-\`readlink -f \$here/../lib/go\`}" |
| 33 | \$here/../lib/go/bin/$1 "\$@" |
| 34 | END |
| 35 | chmod +x ${D}${bindir}/$1 |
| 36 | } |
| 37 | |
| 38 | do_install() { |
| 39 | find ${S} -depth -type d -name testdata -exec rm -rf {} + |
| 40 | |
| 41 | install -d ${D}${bindir} ${D}${libdir}/go |
| 42 | cp --preserve=mode,timestamps -R ${S}/ ${D}${libdir}/ |
| 43 | |
| 44 | for f in ${S}/bin/* |
| 45 | do |
| 46 | make_wrapper `basename $f` |
| 47 | done |
| 48 | } |