Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Test vectors for the cryptography package." |
| 2 | HOMEPAGE = "https://cryptography.io/" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "Apache-2.0 | BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4 \ |
| 6 | file://LICENSE.APACHE;md5=4e168cce331e5c827d4c2b68a6200e1b \ |
| 7 | file://LICENSE.BSD;md5=5ae30ba4123bc4f2fa49aa0b0dce887b" |
| 8 | |
| 9 | # NOTE: Make sure to keep this recipe at the same version as python3-cryptography |
| 10 | # Upgrade both recipes at the same time |
| 11 | |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame^] | 12 | SRC_URI[sha256sum] = "0cbaeb50bdb7f3c9d7a93b26a0462ef6e97c768ca78d902854fe045c30b680c6" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 13 | |
| 14 | PYPI_PACKAGE = "cryptography_vectors" |
| 15 | |
| 16 | inherit pypi setuptools3 |
| 17 | |
| 18 | DEPENDS += " \ |
| 19 | ${PYTHON_PN}-cryptography \ |
| 20 | " |
| 21 | |
| 22 | do_install:append () { |
| 23 | # Remove the sha256 checksum lines for pycache files |
| 24 | sed ${D}${PYTHON_SITEPACKAGES_DIR}/cryptography_vectors-${PV}.dist-info/RECORD -e '/__pycache__/d' -i |
| 25 | } |
| 26 | |
| 27 | BBCLASSEXTEND = "native nativesdk" |
| 28 | |
| 29 | UPSTREAM_CHECK_REGEX = "" |