Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | require gstreamer1.0-plugins-common.inc |
| 2 | |
| 3 | DESCRIPTION = "'Good' GStreamer plugins" |
| 4 | HOMEPAGE = "https://gstreamer.freedesktop.org/" |
| 5 | BUGTRACKER = "https://gitlab.freedesktop.org/gstreamer/gst-plugins-good/-/issues" |
| 6 | |
| 7 | SRC_URI = "https://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-${PV}.tar.xz \ |
| 8 | file://0001-qt-include-ext-qt-gstqtgl.h-instead-of-gst-gl-gstglf.patch \ |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame^] | 9 | file://0001-v4l2-Define-ioctl_req_t-for-posix-linux-case.patch" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 10 | |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame^] | 11 | SRC_URI[sha256sum] = "582e617271e7f314d1a2211e3e3856ae2e4303c8c0d6114e9c4a5ea5719294b0" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 12 | |
| 13 | S = "${WORKDIR}/gst-plugins-good-${PV}" |
| 14 | |
| 15 | LICENSE = "LGPL-2.1-or-later" |
| 16 | LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \ |
| 17 | file://gst/replaygain/rganalysis.c;beginline=1;endline=23;md5=b60ebefd5b2f5a8e0cab6bfee391a5fe" |
| 18 | |
| 19 | DEPENDS += "gstreamer1.0-plugins-base libcap zlib" |
| 20 | RPROVIDES:${PN}-pulseaudio += "${PN}-pulse" |
| 21 | RPROVIDES:${PN}-soup += "${PN}-souphttpsrc" |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 22 | RDEPENDS:${PN}-soup += "${MLPREFIX}${@bb.utils.contains('PACKAGECONFIG', 'soup2', 'libsoup-2.4', 'libsoup', d)}" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 23 | |
| 24 | PACKAGECONFIG_SOUP ?= "soup3" |
| 25 | |
| 26 | PACKAGECONFIG ??= " \ |
| 27 | ${GSTREAMER_ORC} \ |
| 28 | ${PACKAGECONFIG_SOUP} \ |
| 29 | ${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio x11', d)} \ |
| 30 | ${@bb.utils.contains('TUNE_FEATURES', 'm64', 'asm', '', d)} \ |
| 31 | bz2 cairo flac gdk-pixbuf gudev jpeg lame libpng mpg123 speex taglib v4l2 \ |
| 32 | " |
| 33 | |
| 34 | X11DEPENDS = "virtual/libx11 libsm libxrender libxfixes libxdamage" |
| 35 | X11ENABLEOPTS = "-Dximagesrc=enabled -Dximagesrc-xshm=enabled -Dximagesrc-xfixes=enabled -Dximagesrc-xdamage=enabled" |
| 36 | X11DISABLEOPTS = "-Dximagesrc=disabled -Dximagesrc-xshm=disabled -Dximagesrc-xfixes=disabled -Dximagesrc-xdamage=disabled" |
| 37 | |
| 38 | QT5WAYLANDDEPENDS = "${@bb.utils.contains("DISTRO_FEATURES", "wayland", "qtwayland", "", d)}" |
| 39 | |
| 40 | PACKAGECONFIG[asm] = "-Dasm=enabled,-Dasm=disabled,nasm-native" |
| 41 | PACKAGECONFIG[bz2] = "-Dbz2=enabled,-Dbz2=disabled,bzip2" |
| 42 | PACKAGECONFIG[cairo] = "-Dcairo=enabled,-Dcairo=disabled,cairo" |
| 43 | PACKAGECONFIG[dv1394] = "-Ddv1394=enabled,-Ddv1394=disabled,libiec61883 libavc1394 libraw1394" |
| 44 | PACKAGECONFIG[flac] = "-Dflac=enabled,-Dflac=disabled,flac" |
| 45 | PACKAGECONFIG[gdk-pixbuf] = "-Dgdk-pixbuf=enabled,-Dgdk-pixbuf=disabled,gdk-pixbuf" |
| 46 | PACKAGECONFIG[gtk] = "-Dgtk3=enabled,-Dgtk3=disabled,gtk+3" |
| 47 | PACKAGECONFIG[gudev] = "-Dv4l2-gudev=enabled,-Dv4l2-gudev=disabled,libgudev" |
| 48 | PACKAGECONFIG[jack] = "-Djack=enabled,-Djack=disabled,jack" |
| 49 | PACKAGECONFIG[jpeg] = "-Djpeg=enabled,-Djpeg=disabled,jpeg" |
| 50 | PACKAGECONFIG[lame] = "-Dlame=enabled,-Dlame=disabled,lame" |
| 51 | PACKAGECONFIG[libpng] = "-Dpng=enabled,-Dpng=disabled,libpng" |
| 52 | PACKAGECONFIG[libv4l2] = "-Dv4l2-libv4l2=enabled,-Dv4l2-libv4l2=disabled,v4l-utils" |
| 53 | PACKAGECONFIG[mpg123] = "-Dmpg123=enabled,-Dmpg123=disabled,mpg123" |
| 54 | PACKAGECONFIG[pulseaudio] = "-Dpulse=enabled,-Dpulse=disabled,pulseaudio" |
| 55 | PACKAGECONFIG[qt5] = "-Dqt5=enabled,-Dqt5=disabled,qtbase qtdeclarative qtbase-native ${QT5WAYLANDDEPENDS}" |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 56 | PACKAGECONFIG[soup2] = "-Dsoup=enabled,,libsoup-2.4,,,soup3" |
| 57 | PACKAGECONFIG[soup3] = "-Dsoup=enabled,,libsoup,,,soup2" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 58 | PACKAGECONFIG[speex] = "-Dspeex=enabled,-Dspeex=disabled,speex" |
| 59 | PACKAGECONFIG[rpi] = "-Drpicamsrc=enabled,-Drpicamsrc=disabled,userland" |
| 60 | PACKAGECONFIG[taglib] = "-Dtaglib=enabled,-Dtaglib=disabled,taglib" |
| 61 | PACKAGECONFIG[v4l2] = "-Dv4l2=enabled -Dv4l2-probe=true,-Dv4l2=disabled -Dv4l2-probe=false" |
| 62 | PACKAGECONFIG[vpx] = "-Dvpx=enabled,-Dvpx=disabled,libvpx" |
| 63 | PACKAGECONFIG[wavpack] = "-Dwavpack=enabled,-Dwavpack=disabled,wavpack" |
| 64 | PACKAGECONFIG[x11] = "${X11ENABLEOPTS},${X11DISABLEOPTS},${X11DEPENDS}" |
| 65 | |
| 66 | EXTRA_OEMESON += " \ |
| 67 | -Ddoc=disabled \ |
| 68 | -Daalib=disabled \ |
| 69 | -Ddirectsound=disabled \ |
| 70 | -Ddv=disabled \ |
| 71 | -Dlibcaca=disabled \ |
| 72 | -Doss=enabled \ |
| 73 | -Doss4=disabled \ |
| 74 | -Dosxaudio=disabled \ |
| 75 | -Dosxvideo=disabled \ |
| 76 | -Dshout2=disabled \ |
| 77 | -Dtwolame=disabled \ |
| 78 | -Dwaveform=disabled \ |
| 79 | " |
| 80 | |
| 81 | FILES:${PN}-equalizer += "${datadir}/gstreamer-1.0/presets/*.prs" |