blob: fa64d1121662f38db5584dd873640580dafc7c09 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf"
4
5CVE_PRODUCT = "libtiff"
6
7SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \
8 file://libtool2.patch \
9 file://CVE-2017-9935.patch \
10 file://CVE-2017-18013.patch \
11 file://CVE-2018-5784.patch \
Brad Bishopd5ae7d92018-06-14 09:52:03 -070012 file://CVE-2018-10963.patch \
13 file://CVE-2018-8905.patch \
14 file://CVE-2018-7456.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -040015 "
16
17SRC_URI[md5sum] = "54bad211279cc93eb4fca31ba9bfdc79"
18SRC_URI[sha256sum] = "6e7bdeec2c310734e734d19aae3a71ebe37a4d842e0e23dbb1b8921c0026cfcd"
19
20# exclude betas
21UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
22
23inherit autotools multilib_header
24
25CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
26
27PACKAGECONFIG ?= "cxx jpeg zlib lzma \
28 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
29
30PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
31PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
32PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
33PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
34
35# Convert single-strip uncompressed images to multiple strips of specified
36# size (default: 8192) to reduce memory usage
37PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
38
39# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
40PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
41
42# Control picking up YCbCr subsample info. Disable to support files lacking
43# the tag
44PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
45
46# Support a mechanism allowing reading large strips (usually one strip files)
47# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
48PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
49
50PACKAGES =+ "tiffxx tiff-utils"
51FILES_tiffxx = "${libdir}/libtiffxx.so.*"
52FILES_tiff-utils = "${bindir}/*"
53
54do_install_append() {
55 oe_multilib_header tiffconf.h
56}
57
58BBCLASSEXTEND = "native"