Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Name Service Switch module for resolving the local hostname" |
| 2 | DESCRIPTION = "plugin for the GNU Name Service Switch (NSS) functionality of \ |
| 3 | the GNU C Library (glibc) providing host name resolution for the locally \ |
| 4 | configured system hostname as returned by gethostname(2)." |
| 5 | HOMEPAGE = "http://0pointer.de/lennart/projects/nss-myhostname/" |
| 6 | LICENSE = "LGPLv2.1" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2d5025d4aa3495befef8f17206a5b0a1" |
| 8 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 9 | SRC_URI = "http://0pointer.de/lennart/projects/nss-myhostname/nss-myhostname-${PV}.tar.gz \ |
| 10 | file://0001-nss-myhostname-Check-for-nss.h-presense-before-use.patch \ |
| 11 | " |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 12 | |
| 13 | SRC_URI[md5sum] = "d4ab9ac36c053ab8fb836db1cbd4a48f" |
| 14 | SRC_URI[sha256sum] = "2ba744ea8d578d1c57c85884e94a3042ee17843a5294434d3a7f6c4d67e7caf2" |
| 15 | |
| 16 | inherit autotools distro_features_check |
| 17 | |
| 18 | # The systemd has its own copy of nss-myhostname |
| 19 | CONFLICT_DISTRO_FEATURES = "systemd" |
| 20 | |
| 21 | pkg_postinst_${PN} () { |
| 22 | sed -e '/^hosts:/s/\s*\<myhostname\>//' \ |
| 23 | -e 's/\(^hosts:.*\)\(\<files\>\)\(.*\)\(\<dns\>\)\(.*\)/\1\2 myhostname \3\4\5/' \ |
| 24 | -i $D${sysconfdir}/nsswitch.conf |
| 25 | } |
| 26 | |
| 27 | pkg_prerm_${PN} () { |
| 28 | sed -e '/^hosts:/s/\s*\<myhostname\>//' \ |
| 29 | -e '/^hosts:/s/\s*myhostname//' \ |
| 30 | -i $D${sysconfdir}/nsswitch.conf |
| 31 | } |