Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Matchbox Window Manager Desktop" |
| 2 | HOMEPAGE = "http://matchbox-project.org/" |
| 3 | BUGTRACKER = "http://bugzilla.yoctoproject.org/" |
| 4 | |
| 5 | LICENSE = "GPLv2+ & LGPLv2+" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ |
| 7 | file://src/desktop.c;endline=20;md5=36c9bf295e6007f3423095f405af5a2d \ |
| 8 | file://src/main.c;endline=19;md5=2044244f97a195c25b7dc602ac7e9a00" |
| 9 | |
| 10 | DEPENDS = "gtk+3 startup-notification dbus" |
| 11 | SECTION = "x11/wm" |
| 12 | |
| 13 | # SRCREV tagged 2.2 |
| 14 | SRCREV = "6bc67d09da4147e5552fe30011a05a2c59d2f777" |
| 15 | SRC_URI = "git://git.yoctoproject.org/${BPN}-2 \ |
| 16 | file://vfolders/* \ |
| 17 | " |
| 18 | |
| 19 | EXTRA_OECONF = "--enable-startup-notification --with-dbus" |
| 20 | |
| 21 | S = "${WORKDIR}/git" |
| 22 | |
| 23 | inherit autotools pkgconfig distro_features_check |
| 24 | |
| 25 | # The startup-notification requires x11 in DISTRO_FEATURES |
| 26 | REQUIRED_DISTRO_FEATURES = "x11" |
| 27 | |
| 28 | do_install_append() { |
| 29 | install -d ${D}${datadir}/matchbox/vfolders/ |
| 30 | install -m 0644 ${WORKDIR}/vfolders/* ${D}${datadir}/matchbox/vfolders/ |
| 31 | } |
| 32 | |
| 33 | FILES_${PN} += "${datadir}/matchbox/vfolders/" |