Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 1 | # Copyright (C) 2020 Armin Kuster <akuster808@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | DESCRIPTION = "Musl-nscd is an implementation of the NSCD protocol, suitable for use with musl and with standard NSS modules" |
| 5 | HOMEPAGE = "https://github.com/pikhq/musl-nscd" |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=9bf479a145bcaff8489e743da58afeee" |
| 8 | SECTION = "utils" |
| 9 | |
| 10 | PV = "1.0.2" |
| 11 | |
| 12 | CFLAGS += "-fcommon" |
| 13 | |
| 14 | SRCREV = "8f278675e1b6a3a02c8ee1b8ca000f80570dc5d6" |
| 15 | SRC_URI = "git://github.com/pikhq/musl-nscd" |
| 16 | |
| 17 | UPSTREAM_CHECK_COMMITS = "1" |
| 18 | |
| 19 | inherit autotools-brokensep |
| 20 | |
| 21 | S = "${WORKDIR}/git" |
| 22 | |
| 23 | do_configure () { |
| 24 | # no debug set -s flag |
| 25 | sed -i -e 's/LDFLAGS_AUTO=-s/LDFLAGS_AUTO=/' ${S}/configure |
| 26 | ${S}/configure ${CONFIGUREOPTS} ${EXTRA_OECONF} |
| 27 | } |
| 28 | |
| 29 | do_compile () { |
| 30 | oe_runmake |
| 31 | } |
| 32 | |
| 33 | do_install () { |
| 34 | make DESTDIR=${D} install |
| 35 | } |
| 36 | |
| 37 | COMPATIBLE_HOST = ".*-musl.*" |