Andrew Geissler | c9f7865 | 2020-09-18 14:11:35 -0500 | [diff] [blame] | 1 | SECTION = "console/network" |
| 2 | SUMMARY = "dhcpcd - a DHCP client" |
| 3 | DESCRIPTION = "dhcpcd runs on your machine and silently configures your \ |
| 4 | computer to work on the attached networks without trouble \ |
| 5 | and mostly without configuration." |
| 6 | |
| 7 | HOMEPAGE = "http://roy.marples.name/projects/dhcpcd/" |
| 8 | |
| 9 | LICENSE = "BSD-2-Clause" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=9674cc803c5d71306941e6e8b5c002f2" |
| 11 | |
| 12 | UPSTREAM_CHECK_URI = "https://roy.marples.name/downloads/dhcpcd/" |
| 13 | |
| 14 | SRC_URI = "https://roy.marples.name/downloads/${BPN}/${BPN}-${PV}.tar.xz \ |
| 15 | file://0001-remove-INCLUDEDIR-to-prevent-build-issues.patch \ |
| 16 | file://dhcpcd.service \ |
| 17 | file://dhcpcd@.service \ |
| 18 | " |
| 19 | |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame^] | 20 | SRC_URI[sha256sum] = "6d49af5e766a2515e6366e4f669663df04ecdf90a1a60ddb1d7a2feb4b5d2566" |
Andrew Geissler | c9f7865 | 2020-09-18 14:11:35 -0500 | [diff] [blame] | 21 | |
Andrew Geissler | c3d88e4 | 2020-10-02 09:45:00 -0500 | [diff] [blame] | 22 | inherit pkgconfig autotools-brokensep systemd useradd |
Andrew Geissler | c9f7865 | 2020-09-18 14:11:35 -0500 | [diff] [blame] | 23 | |
| 24 | SYSTEMD_SERVICE_${PN} = "dhcpcd.service" |
| 25 | |
| 26 | PACKAGECONFIG ?= "udev ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}" |
| 27 | |
| 28 | PACKAGECONFIG[udev] = "--with-udev,--without-udev,udev,udev" |
| 29 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6" |
Andrew Geissler | 4c19ea1 | 2020-10-27 13:52:24 -0500 | [diff] [blame] | 30 | # ntp conflicts with chrony |
| 31 | PACKAGECONFIG[ntp] = "--with-hook=ntp, , ,ntp" |
| 32 | PACKAGECONFIG[chrony] = "--with-hook=ntp, , ,chrony" |
| 33 | PACKAGECONFIG[ypbind] = "--with-eghook=yp, , ,ypbind-mt" |
Andrew Geissler | c9f7865 | 2020-09-18 14:11:35 -0500 | [diff] [blame] | 34 | |
Andrew Geissler | c3d88e4 | 2020-10-02 09:45:00 -0500 | [diff] [blame] | 35 | EXTRA_OECONF = "--enable-ipv4 \ |
| 36 | --dbdir=${localstatedir}/lib/${BPN} \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame^] | 37 | --sbindir=${base_sbindir} \ |
Andrew Geissler | c3d88e4 | 2020-10-02 09:45:00 -0500 | [diff] [blame] | 38 | --runstatedir=/run \ |
Andrew Geissler | 4c19ea1 | 2020-10-27 13:52:24 -0500 | [diff] [blame] | 39 | --enable-privsep \ |
| 40 | --privsepuser=dhcpcd \ |
| 41 | --with-hooks \ |
| 42 | --with-eghooks \ |
Andrew Geissler | c3d88e4 | 2020-10-02 09:45:00 -0500 | [diff] [blame] | 43 | " |
| 44 | |
| 45 | USERADD_PACKAGES = "${PN}" |
| 46 | USERADD_PARAM_${PN} = "--system -d ${localstatedir}/lib/${BPN} -M -s /bin/false -U dhcpcd" |
Andrew Geissler | c9f7865 | 2020-09-18 14:11:35 -0500 | [diff] [blame] | 47 | |
| 48 | do_install_append () { |
| 49 | # install systemd unit files |
| 50 | install -d ${D}${systemd_unitdir}/system |
| 51 | install -m 0644 ${WORKDIR}/dhcpcd*.service ${D}${systemd_unitdir}/system |
Andrew Geissler | c3d88e4 | 2020-10-02 09:45:00 -0500 | [diff] [blame] | 52 | |
| 53 | chmod 700 ${D}${localstatedir}/lib/${BPN} |
| 54 | chown dhcpcd:dhcpcd ${D}${localstatedir}/lib/${BPN} |
Andrew Geissler | c9f7865 | 2020-09-18 14:11:35 -0500 | [diff] [blame] | 55 | } |
| 56 | |
| 57 | FILES_${PN}-dbg += "${libdir}/dhcpcd/dev/.debug" |