Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "Python GObject bindings" |
| 2 | SECTION = "devel/python" |
| 3 | LICENSE = "LGPLv2.1" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7" |
| 5 | |
| 6 | GNOMEBASEBUILDCLASS = "meson" |
| 7 | inherit gnomebase distutils3-base gobject-introspection upstream-version-is-even |
| 8 | |
| 9 | DEPENDS += "python3 glib-2.0" |
| 10 | |
| 11 | SRCNAME="pygobject" |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 12 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 13 | SRC_URI = " \ |
| 14 | http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \ |
| 15 | file://0001-Do-not-build-tests.patch \ |
| 16 | " |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame^] | 17 | SRC_URI[sha256sum] = "0372d1bb9122fc19f500a249b1f38c2bb67485000f5887497b4b205b3e7084d5" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 18 | |
| 19 | UNKNOWN_CONFIGURE_WHITELIST = "introspection" |
| 20 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 21 | S = "${WORKDIR}/${SRCNAME}-${PV}" |
| 22 | |
| 23 | PACKAGECONFIG ??= "${@bb.utils.contains_any('DISTRO_FEATURES', [ 'directfb', 'wayland', 'x11' ], 'cairo', '', d)}" |
| 24 | |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 25 | RDEPENDS_${PN} += "python3-pkgutil" |
| 26 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 27 | # python3-pycairo is checked on configuration -> DEPENDS |
| 28 | # we don't link against python3-pycairo -> RDEPENDS |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame^] | 29 | PACKAGECONFIG[cairo] = "-Dpycairo=enabled,-Dpycairo=disabled, cairo python3-pycairo, python3-pycairo" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 30 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 31 | BBCLASSEXTEND = "native" |
| 32 | PACKAGECONFIG_class-native = "" |