Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "JSON-GLib implements a full JSON parser using GLib and GObject" |
| 2 | DESCRIPTION = "Use JSON-GLib it is possible to parse and generate valid JSON\ |
| 3 | data structures, using a DOM-like API. JSON-GLib also offers GObject \ |
| 4 | integration, providing the ability to serialize and deserialize GObject \ |
| 5 | instances to and from JSON data types." |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 6 | HOMEPAGE = "https://wiki.gnome.org/Projects/JsonGlib" |
| 7 | BUGTRACKER = "https://gitlab.gnome.org/GNOME/json-glib/issues" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 8 | |
| 9 | LICENSE = "LGPLv2.1" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34" |
| 11 | |
| 12 | DEPENDS = "glib-2.0" |
| 13 | |
| 14 | GNOMEBASEBUILDCLASS = "meson" |
Andrew Geissler | c9f7865 | 2020-09-18 14:11:35 -0500 | [diff] [blame] | 15 | inherit gnomebase lib_package gobject-introspection gtk-doc gettext ptest-gnome manpages upstream-version-is-even |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame^] | 16 | GIR_MESON_ENABLE_FLAG = 'enabled' |
| 17 | GIR_MESON_DISABLE_FLAG = 'disabled' |
| 18 | GTKDOC_MESON_OPTION = "gtk_doc" |
| 19 | GTKDOC_MESON_ENABLE_FLAG = 'enabled' |
| 20 | GTKDOC_MESON_DISABLE_FLAG = 'disabled' |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 21 | |
Andrew Geissler | c9f7865 | 2020-09-18 14:11:35 -0500 | [diff] [blame] | 22 | SRC_URI += "file://run-ptest \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame^] | 23 | file://0001-json-glib-json-enum-types.c.in-fix-build-reproducibi.patch" |
| 24 | SRC_URI[archive.sha256sum] = "0d7c67602c4161ea7070fab6c5823afd9bd7f7bc955f652a50d3753b08494e73" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 25 | |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame^] | 26 | PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 27 | PACKAGECONFIG[manpages] = "-Dman=true,-Dman=false,libxslt-native xmlto-native" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame^] | 28 | PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 29 | |
| 30 | BBCLASSEXTEND = "native nativesdk" |
| 31 | |
| 32 | # Currently it's not possible to disable gettext in Meson, so we need to force |
| 33 | # this back on. |
| 34 | USE_NLS_class-native = "yes" |