Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "IPC library used by GnuPG and GPGME" |
| 2 | HOMEPAGE = "http://www.gnupg.org/related_software/libassuan/" |
| 3 | BUGTRACKER = "https://bugs.g10code.com/gnupg/index" |
| 4 | |
| 5 | LICENSE = "GPLv3+ & LGPLv2.1+" |
| 6 | LICENSE_${PN} = "LGPLv2.1+" |
| 7 | LICENSE_${PN}-doc = "GPLv3+" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949 \ |
| 9 | file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \ |
| 10 | file://src/assuan.c;endline=20;md5=ab92143a5a2adabd06d7994d1467ea5c\ |
| 11 | file://src/assuan-defs.h;endline=20;md5=15d950c83e82978e35b35e790d7e4d39" |
| 12 | |
| 13 | DEPENDS = "libgpg-error" |
| 14 | |
| 15 | UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html" |
| 16 | SRC_URI = "${GNUPG_MIRROR}/libassuan/libassuan-${PV}.tar.bz2 \ |
| 17 | file://libassuan-add-pkgconfig-support.patch \ |
| 18 | " |
| 19 | |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame^] | 20 | SRC_URI[sha256sum] = "c080ee96b3bd519edd696cfcebdecf19a3952189178db9887be713ccbcb5fbf0" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 21 | |
| 22 | BINCONFIG = "${bindir}/libassuan-config" |
| 23 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 24 | inherit autotools texinfo binconfig-disabled pkgconfig multilib_header |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 25 | |
| 26 | do_configure_prepend () { |
| 27 | # Else these could be used in preference to those in aclocal-copy |
| 28 | rm -f ${S}/m4/*.m4 |
| 29 | } |
| 30 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 31 | do_install_append () { |
| 32 | oe_multilib_header assuan.h |
| 33 | } |
| 34 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 35 | BBCLASSEXTEND = "native nativesdk" |