Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Enca is an Extremely Naive Charset Analyser" |
| 2 | SECTION = "libs" |
Andrew Geissler | ac970dd | 2021-02-12 15:32:45 -0600 | [diff] [blame] | 3 | HOMEPAGE = "https://cihar.com/software/enca/" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 4 | |
| 5 | DEPENDS += "gettext-native" |
| 6 | |
| 7 | LICENSE = "GPLv2" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=24b9569831c46d4818450b55282476b4" |
| 9 | |
Andrew Geissler | ac970dd | 2021-02-12 15:32:45 -0600 | [diff] [blame] | 10 | SRC_URI = "https://dl.cihar.com/enca/enca-${PV}.tar.gz \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 11 | file://dont-run-tests.patch \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 12 | file://makefile-remove-tools.patch \ |
| 13 | file://libenca-003-iconv.patch " |
| 14 | |
Andrew Geissler | 97771a3 | 2021-03-05 15:23:11 -0600 | [diff] [blame] | 15 | SRC_URI[sha256sum] = "4c305cc59f3e57f2cfc150a6ac511690f43633595760e1cb266bf23362d72f8a" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 16 | |
| 17 | inherit autotools |
| 18 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 19 | do_configure:prepend() { |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 20 | # remove failing test which checks for something that isn't even used |
| 21 | sed -i -e '/ye_FUNC_SCANF_MODIF_SIZE_T/d' ${S}/configure.ac |
| 22 | } |
| 23 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 24 | do_configure:append() { |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 25 | sed -i s:-I/usr/include::g ${B}/Makefile |
| 26 | sed -i s:-I/usr/include::g ${B}/*/Makefile |
| 27 | } |
| 28 | |
| 29 | do_compile() { |
| 30 | cd ${S}/tools && ${BUILD_CC} -o make_hash make_hash.c |
| 31 | cd ${B} |
| 32 | oe_runmake |
| 33 | } |
| 34 | |