Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | DESCRIPTION = "A python module for system storage configuration" |
| 2 | HOMEPAGE = "http://fedoraproject.org/wiki/blivet" |
| 3 | LICENSE = "LGPLv2+" |
| 4 | SECTION = "devel/python" |
| 5 | |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 7 | |
| 8 | S = "${WORKDIR}/git" |
| 9 | B = "${S}" |
| 10 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 11 | SRCREV = "f7d9027e4fdad11187980e73726cd75a2dc962c2" |
| 12 | SRC_URI = "git://github.com/storaged-project/blivet.git;branch=3.4-release \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 13 | file://0002-run_program-support-timeout.patch \ |
| 14 | file://0003-support-infinit-timeout.patch \ |
| 15 | file://0004-fix-new.roots-object-is-not-iterable.patch \ |
| 16 | file://0005-fix-incorrect-timeout-while-system-time-changed.patch \ |
| 17 | file://0006-tweak-btrfs-packages.patch \ |
| 18 | file://0007-invoking-mount-with-infinite-timeout.patch \ |
| 19 | file://0008-use-oe-variable-to-replace-hardcoded-dir.patch \ |
| 20 | file://0009-invoking-fsck-with-infinite-timeout.patch \ |
| 21 | file://0010-invoking-mkfs-with-infinite-timeout.patch \ |
| 22 | file://0011-invoking-dd-with-infinite-timeout.patch \ |
| 23 | " |
| 24 | |
| 25 | UPSTREAM_CHECK_GITTAGREGEX = "blivet-(?P<pver>\d+(\.\d+)+)$" |
| 26 | |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 27 | inherit features_check |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 28 | REQUIRED_DISTRO_FEATURES = "systemd" |
| 29 | |
| 30 | inherit setuptools3 python3native |
| 31 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 32 | RDEPENDS:${PN} += "python3-pykickstart python3-pyudev \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 33 | parted python3-pyparted multipath-tools \ |
| 34 | lsof cryptsetup libblockdev \ |
| 35 | libbytesize \ |
| 36 | " |
| 37 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 38 | FILES:${PN} += " \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 39 | ${datadir}/dbus-1/system-services \ |
| 40 | " |
| 41 | |
| 42 | inherit systemd |
| 43 | |
| 44 | SYSTEMD_AUTO_ENABLE = "disable" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 45 | SYSTEMD_SERVICE:${PN} = "blivet.service" |