Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "VA-API support to GStreamer" |
| 2 | HOMEPAGE = "https://gstreamer.freedesktop.org/" |
| 3 | DESCRIPTION = "gstreamer-vaapi consists of a collection of VA-API \ |
| 4 | based plugins for GStreamer and helper libraries: `vaapidecode', \ |
| 5 | `vaapiconvert', and `vaapisink'." |
| 6 | |
| 7 | REALPN = "gstreamer-vaapi" |
| 8 | |
| 9 | LICENSE = "LGPL-2.1-or-later" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c" |
| 11 | |
| 12 | SRC_URI = "https://gstreamer.freedesktop.org/src/${REALPN}/${REALPN}-${PV}.tar.xz" |
| 13 | |
| 14 | SRC_URI[sha256sum] = "87fbf6c537af9079c99a9aefe951da119e16e5bcc9cc8614f5035f062bf21137" |
| 15 | |
| 16 | S = "${WORKDIR}/${REALPN}-${PV}" |
| 17 | DEPENDS = "libva gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad" |
| 18 | |
| 19 | inherit meson pkgconfig features_check upstream-version-is-even |
| 20 | |
| 21 | REQUIRED_DISTRO_FEATURES ?= "opengl" |
| 22 | |
| 23 | EXTRA_OEMESON += " \ |
| 24 | -Ddoc=disabled \ |
| 25 | -Dexamples=disabled \ |
| 26 | -Dtests=enabled \ |
| 27 | " |
| 28 | |
| 29 | PACKAGES =+ "${PN}-tests" |
| 30 | |
| 31 | # OpenGL packageconfig factored out to make it easy for distros |
| 32 | # and BSP layers to pick either glx, egl, or no GL. By default, |
| 33 | # try detecting X11 first, and if found (with OpenGL), use GLX, |
| 34 | # otherwise try to check if EGL can be used. |
| 35 | PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'glx', \ |
| 36 | bb.utils.contains('DISTRO_FEATURES', 'opengl', 'egl', \ |
| 37 | '', d), d)}" |
| 38 | |
| 39 | PACKAGECONFIG ??= "drm encoders \ |
| 40 | ${PACKAGECONFIG_GL} \ |
| 41 | ${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}" |
| 42 | |
| 43 | PACKAGECONFIG[drm] = "-Dwith_drm=yes,-Dwith_drm=no,udev libdrm" |
| 44 | PACKAGECONFIG[egl] = "-Dwith_egl=yes,-Dwith_egl=no,virtual/egl" |
| 45 | PACKAGECONFIG[encoders] = "-Dwith_encoders=yes,-Dwith_encoders=no" |
| 46 | PACKAGECONFIG[glx] = "-Dwith_glx=yes,-Dwith_glx=no,virtual/libgl" |
| 47 | PACKAGECONFIG[wayland] = "-Dwith_wayland=yes,-Dwith_wayland=no,wayland-native wayland wayland-protocols" |
| 48 | PACKAGECONFIG[x11] = "-Dwith_x11=yes,-Dwith_x11=no,virtual/libx11 libxrandr libxrender" |
| 49 | |
| 50 | FILES:${PN} += "${libdir}/gstreamer-*/*.so" |
| 51 | FILES:${PN}-dbg += "${libdir}/gstreamer-*/.debug" |
| 52 | FILES:${PN}-dev += "${libdir}/gstreamer-*/*.a" |
| 53 | FILES:${PN}-tests = "${bindir}/*" |