Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Enchant Spell checker API Library" |
| 2 | DESCRIPTION = "A library (and command-line program) that wraps a number of \ |
| 3 | different spelling libraries and programs with a consistent interface." |
| 4 | SECTION = "libs" |
| 5 | HOMEPAGE = "https://abiword.github.io/enchant/" |
| 6 | BUGTRACKER = "https://github.com/AbiWord/enchant/issues/" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 7 | LICENSE = "LGPL-2.1-or-later" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c" |
| 9 | |
| 10 | DEPENDS = "glib-2.0" |
| 11 | |
| 12 | inherit autotools pkgconfig |
| 13 | |
| 14 | SRC_URI = "https://github.com/AbiWord/enchant/releases/download/v${PV}/enchant-${PV}.tar.gz" |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 15 | SRC_URI[sha256sum] = "3da12103f11cf49c3cf2fd2ce3017575c5321a489e5b9bfa81dd91ec413f3891" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 16 | |
| 17 | UPSTREAM_CHECK_URI = "https://github.com/AbiWord/enchant/releases" |
| 18 | |
| 19 | S = "${WORKDIR}/enchant-${PV}" |
| 20 | |
| 21 | EXTRA_OEMAKE = "pkgdatadir=${datadir}/enchant-2" |
| 22 | |
| 23 | PACKAGECONFIG ??= "aspell" |
| 24 | PACKAGECONFIG[aspell] = "--with-aspell,--without-aspell,aspell,aspell" |
| 25 | PACKAGECONFIG[hunspell] = "--with-hunspell,--without-hunspell,hunspell,hunspell" |
| 26 | |
| 27 | FILES:${PN} += " \ |
| 28 | ${datadir}/enchant-2 \ |
| 29 | ${libdir}/enchant-2 \ |
| 30 | " |
| 31 | FILES:${PN}-staticdev += "${libdir}/enchant-2/*.a" |