Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "HTTP/2 C Library and tools" |
| 2 | HOMEPAGE = "https://nghttp2.org/" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=764abdf30b2eadd37ce47dcbce0ea1ec" |
| 6 | |
| 7 | UPSTREAM_CHECK_URI = "https://github.com/nghttp2/nghttp2/releases" |
| 8 | |
| 9 | SRC_URI = "\ |
| 10 | https://github.com/nghttp2/nghttp2/releases/download/v${PV}/nghttp2-${PV}.tar.xz \ |
| 11 | file://0001-fetch-ocsp-response-use-python3.patch \ |
| 12 | " |
| 13 | SRC_URI[sha256sum] = "68271951324554c34501b85190f22f2221056db69f493afc3bbac8e7be21e7cc" |
| 14 | |
| 15 | inherit cmake manpages python3native |
| 16 | PACKAGECONFIG[manpages] = "" |
| 17 | |
| 18 | # examples are never installed, and don't need to be built in the |
| 19 | # first place |
| 20 | EXTRA_OECMAKE = "-DENABLE_EXAMPLES=OFF -DENABLE_APP=OFF -DENABLE_HPACK_TOOLS=OFF" |
| 21 | |
| 22 | PACKAGES =+ "lib${BPN} ${PN}-client ${PN}-proxy ${PN}-server" |
| 23 | |
| 24 | RDEPENDS:${PN} = "${PN}-client (>= ${PV}) ${PN}-proxy (>= ${PV}) ${PN}-server (>= ${PV})" |
| 25 | RDEPENDS:${PN}:class-native = "" |
| 26 | RDEPENDS:${PN}-proxy = "openssl python3-core python3-io python3-shell" |
| 27 | |
| 28 | ALLOW_EMPTY:${PN} = "1" |
| 29 | FILES:${PN} = "" |
| 30 | FILES:lib${BPN} = "${libdir}/*${SOLIBS}" |
| 31 | FILES:${PN}-client = "${bindir}/h2load ${bindir}/nghttp" |
| 32 | FILES:${PN}-proxy = "${bindir}/nghttpx ${datadir}/${BPN}/fetch-ocsp-response" |
| 33 | FILES:${PN}-server = "${bindir}/nghttpd" |
| 34 | |
| 35 | BBCLASSEXTEND = "native nativesdk" |