Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame^] | 1 | DESCRIPTION = "OCI systemd hook enables users to run systemd in docker and OCI" |
| 2 | SECTION = "console/utils" |
| 3 | LICENSE = "GPLv3" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d32239bcb673463ab874e80d47fae504" |
| 5 | PRIORITY = "optional" |
| 6 | |
| 7 | DEPENDS = "yajl util-linux" |
| 8 | |
| 9 | SRCREV = "ca515c1f399bd0b16e94b7c34aa1ef20498beca6" |
| 10 | SRC_URI = "git://github.com/projectatomic/oci-systemd-hook \ |
| 11 | file://0001-selinux-drop-selinux-support.patch \ |
| 12 | file://0001-configure-drop-selinux-support.patch \ |
| 13 | " |
| 14 | |
| 15 | PV = "0.0.1+git${SRCPV}" |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | inherit autotools pkgconfig |
| 19 | |
| 20 | PACKAGECONFIG ??= "" |
| 21 | PACKAGECONFIG[selinux] = ",,libselinux" |
| 22 | |
| 23 | EXTRA_OECONF += "--libexecdir=${libexecdir}/oci/hooks.d" |
| 24 | |
| 25 | # nothing to compile, we do it all in the install task |
| 26 | do_compile[noexec] = "1" |
| 27 | |
| 28 | do_install() { |
| 29 | # Avoid building docs, and other artifacts by surgically calling the |
| 30 | # semi-internal target of "install-exec-am" |
| 31 | oe_runmake 'DESTDIR=${D}' install-exec-am |
| 32 | } |
| 33 | |
| 34 | FILES_${PN} += "${libexecdir}/oci/hooks.d/" |
| 35 | |